Showing results for 
Search instead for 
Did you mean: 

z790i Strix dead header?

Level 7
I have the Lian Li q58 and the Asus z790i Strix the q58 has its own rgb and fan hub. I plugged in my 5v rgb devices into the hub and plugged the hub into the only 5v header on the motherboard and non of the devices are working the rgb is off. I installled armoury crate and it also does not detect anything on the header. I the uninstalled armoury crate with uninstall tool and tried both signal rgb and open rgb and the same result. I then unplugged the hub and tried each rgb device individually on the motherboard header and still nothing. Is my 5v header doa or am I missing something? It’s brand new btw and I updated the bios to latest version.

Update: Okay the whole bottom part of the m.2 slot is not working, i plugged my m.2 and the bios does not recognize it, both 5v and 12v headers do not function. I thought it was maybe my fault by overloading the 5v header, but nothing is working not even the 12v header which i plugged in a single 12v fan and it would not light up. The second m.2 slot that attaches to the bottom slot works perfectly fine and loads Windows right away.

Pictures for reference:

Update 2: The bottom piece that is not working also plugs into the motherboard, i unscrewed it and reseated it and everything works now. I will leave this here just in case anyone runs into the same problem.