cancel
Showing results for 
Search instead for 
Did you mean: 

Z790 Thunderbolt causing boot delay [ProArt Z790-CREATOR WIFI ]

inthevidual
Level 7

Hi,

I'm having a weird issue with the Thunderbolt on my ProArt Z790-CREATOR WIFI .

Enabling it introduces a black screen/delay of about 20 seconds between the POST text disappearing and boot loader showing, only on cold boots. This happens even without any devices attached to the TB ports, and regardless of operating system (I have GRUB/Ubuntu installed on one disk, Windows 11 on another and the delay is identical regardless of which one I choose).

I have tried experimenting with a myriad of Thunderbolt, ASPM and power saving settings, from disabling everything (including the obvious Thunderbolt Boot Support) to enabling everything, but nothing of this makes a difference.

If I disable Thunderbolt altogether [Discrete Thunderbolt Support] in BIOS, the problem goes away, but so does my Thunderbolt of course.
The delay happens only on cold boots – on warm boots, the OS starts loading almost instantly after POST.

Does anyone have any idea on how I might solve this? All firmware and drivers updated to their latest versions AFAIK:
BIOS 2202/Intel ME version 16.1.30.2307

192 Views
2 REPLIES 2

JohnAb
Level 17

I don't know enough about the technical differences between Thunderbolt ports and USB-C ports (apart from the speed difference of course) but look to see if there is a PD firmware update available for your board. It's related to USB-C power delivery and will be on the motherboard support page in the firmware section. No idea if this could help in your case, but have you tried the update, assuming you have one available?

I'm just thinking that problems on cold boot could be something to do with the USB/Thunderbolt power delivery system as the board initialises.  Only a suggestion, I have no idea if it will help. 

Z690 Hero, 12900K, BIOS 3501, MEI 2406.5.5.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Thanks for the suggestion, but no, PD firmware is fully updated, and I think USB/TB, at least on this board, are functionally separate despite the port similarity – disabling TB does not affect USB-C.