cancel
Showing results for 
Search instead for 
Did you mean: 

Z790-P Bios Issue (1641)

jcbell3
Level 8

Just bought 2 Z790-P motherboards. updated the bios on both to 1641. was having some video issues so i figured i would try downgrading the bios to an earlier version. every time it read the CAP file, it told me it was not a proper bios (on both motherboards). I even tried having it read the 1641 bios CAP file and got the same result. I think there is an issue with the bios. reached out to ASUS technical support and that has been an effort in futility. got back a bunch of links on how to install the bios even though i told them that was not the issue. finally told them i have been buying ASUS motherboards (for myself and clients) for years (found an invoice from 2006) and the only issue i ever had was a bios that would not support a newer CPU (had to send the chip in for reprogramming I  think). And, would you believe it, i got a response saying i would have to ship the motherboard back for bios reprogramming if it didn't support CPU! Anyway, support apparently reads but doesn't understand. anybody have any suggestions or should i just wait until a newer bios comes out and see if that works. These are client computers so before i ship, i would really like to make sure all my ducks are in order. Thanks.

497 Views
6 REPLIES 6

Nate152
Moderator

Hello jcbell3

I've got the "not a proper bios file" when updating the bios from one of two reasons.

1) You didn't rename the bios file.

2) You're trying to roll back the bios too far.  Normally, ASUS will list a bios version that you can't roll back past. I'm not seeing a version you can't roll back past for your motherboard, but try versions 1630 or 1611.

PRIME Z790-P|Motherboards|ASUS Global

What gpu are you using and what issue are you having?

 

 

 

 

 

 

Tried renaming and not renaming (using the biosrename). also tried the "flash"
at startup. nothing worked.

Was trying to roll back to the previous version (1630). also tried the original
1641 file that was used to update the bios. again no success. I am using the GPU
in the Intel CPU (Intel Core i5-12600K Desktop Processor with Integrated Graphics and
10 (6P+4E) Cores up to 4.9 GHz Unlocked LGA1700 600 Series Chipset 125W - amazon
description). Could the GPU be part of the issue? thanks for the response.

Nate152
Moderator

Thank you,

Let's make sure you're doing it correctly, it might be a good idea to delete everything off of your usb flash drive.

I made a quick video to be sure you renamed the bios file and put it on your usb flash drive, I used bios 1630. 

Once you have the bios file on your usb flash drive, enter the bios and go to the tool tab, EZ-Flash, find your usb flash drive with the bios file and try updating.

 

 

I have been updating asus bios for 25 years or more. never had a problem with doing it wrong. asus tech support is now trying to replicate the issue (wanted all my information about the systems). Will post what they come up with. fwiw, the same process was used to update the shipped bios to 1641 without anything odd or issues.

Got a response back from asus tech support and they sent me another bios file which worked. part of this was my problem (I think) in that i downloaded the bios for z790-P and not z790-P Wifi. however, it is interesting to note that there is a newer bios from 3/19 (version 1645) so I am guessing they fixed something. anyway hope this helps somebody.

Nate152
Moderator

Ah, I see why it wasn't working now.

Good to hear the easy fix was the right motherboard bios.