Showing results for 
Search instead for 
Did you mean: 

z790 Maximus Hero with 64GB Corsair (2x32) - RAM locking up/freezing, any thoughts?

Level 7
I upgraded to 13th gen recently and got the Asus ROG Maximus z790 Hero motherboard and a i9 13900KS CPU. All other components were taken from my previous build and have worked fine for almost 2 years.

After putting everything together and doing a fresh install of Windows 11, I am having random stability issues and I am 99% certain it is my RAM, which is on the QVL list for this mother board. The problem comes after I boot into Windows 11 at random times (sometimes an hour, sometimes 2 minutes, but always happens), the ram RGB lights freeze and the system locks or screen goes black. I have to shut down (sometimes hard reboot). I thought it was Armory Crate and iCue software issues, but I did another fresh install of Windows 11 and did not add those programs, but it still happens. I have tried setting the bios tweaker menu to XMP 1, XMP 2, and Auto and they all seem to fail.

I am wondering if anyone has any thoughts as I know this RAM was fine on my z690 mobo, so I'm just so confused why this is happening. If I do use iCue, I get the red triangle of death saying it is no longer receiving data from the DRAM when this happens. Here are my components:
Asus ROG Maximus Z90 Hero mobo
Intel 13900KS i9 CPU
Corsair Dominator Platinum RGB 64GB CMT64GX5M2B5200 DDR5 5200 memory
Asus ROG Strix 4090 OC
Samsung 980 SSD drives (1tb, 2x2TB)

From what I have been reading I am thinking either z790 has issues with 64GB and maybe I should go down to 32, but I'd really prefer to keep everything as is if I can figure it out. Any thoughts?

Level 8
Do you have 4 sticks (4X16) or two sticks (2X32)? I have 2 sticks (2X32) of GSkill Z5 DDR5 6000 RAM in my Z790 running with no problems at XMP 6000. I also have ASUS Armoury Crate and Corsair's iCUE running, and at times it seems like they are fighting each other, but they haven't crashed my system. Sometimes the lighting schemes don't function like I had them setup.

I am aware most boards don't like 4 sticks of RAM which results in the systems running at memory speeds less than the rated maximum speed for that particular RAM, but that doesn't usually result in system crashes and behavior you have described.

Maybe one or more of your sticks are bad and you need to shuffle them in and out and see if the problem goes away. Or possibly one of the channels on your board is bad and you need to RMA the motherboard.

Thanks you - I have 2 sticks of ram (2x32). Last night I went to microcenter and decided to get new ram to try, this time I got faster ram (DDR5 6200), same Brand (Corsair), but only 32GB (2x16 sticks). It seems to be working better, but it is doing the exact same thing - locking up randomly and I have to do a full system restart/shut down to get it back. This is so odd, but now I am thinking that its the BIOS - I am using the latest, 0813, but I see a few other threads on this forum about memory issues on 813. I think I am going to try and downgrade a bit and see what happens. There is no way that both of these ram sticks are bad, and both run memtest with no issue. They are also both on the QVL list so its just weird.

Super Moderator

See sticky regarding XMP

You may want to try XMP2 and XMP Tweaked before tuning the system further.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090