Showing results for 
Search instead for 
Did you mean: 

Z790 Maximus Hero ACCESS_VIOLATION (c0000005) in multiple apps/games

Level 9

I'm battling with this issue since I've built a new PC, so about 4-5 months now, and I've tried many things but no luck, which leads me here as I believe it can be some weird hardware issue (at this point I'm suspecting Motherboard).

I'm getting ACCESS_VIOLATION (c0000005) errors in multiple applications and games. Crash happens randomly, sometimes it manages not to crash for 2-3hrs and sometimes would crash within ~15 minutes of launching an application. Most frequently crashes happen in Corsair iCue, as well as in the games like COD MW2, Dota2, Cyberpunk 2077 and only in a couple rare instances Spotify, Brave Browser, Elgato Stream deck.

In all those instances app just crashes without any error message and I can see (ACCESS_VIOLATION c0000005) error code in Windows Event Viewer. Some games like Dota2 and Cyberpunk would also have same ACCESS_VIOLATION (c0000005) error in error logs.

I'm pretty sure I can rule out my GPU, RAM and M2 SSD as: 

  • I've went through 3 sets of RAM (all of them can be found on the supported list for this MB). Currently I have Corsair 32GB KIT DDR5 7200MHz CL34 Vengeance Black (Tested each ram stick separately in MemTest86 twice (with and without XMP) - passed in all tests, although I've tested only 1 RAM slot).
  • Tested with 2 different GPUs (STRIX 4090 and Evga 3080). I can also consistently run 3DMark bench test back to back several times without any crashes.
  • Did a short and an extended test for m2 ssd (WD black sn850x) both from BIOS and WD Dashboard app. As well as tested it on different PC.

I've tried:

  • Disabling HAGS
  • Disabling Core Isolation
  • SFC, Disk checks
  • Disabling XMP completely
  • Trying different XMP Profiles (XMP I, XMP II, XMP Tweaked)
  • Lowering Power limit for GPU
  • Disabling DEP
  • Disabling Hyper - V
  • Running apps as an admin
  • Monitoring all possible sensors for high thermals - not even close to limits
  • Searched for all possible threads related to (c0000005) error and tried to apply all suggested fixes that I can't remember already, as all this is happening in a span of 4-5 months.

Each time I was swapping the hardware or playing with various settings combination from the list above, I did full clean OS installs (tried both Win 10 and Win 11). All drivers, BIOS, OS and firmware are always up to date. Same issue happened on previous versions of BIOS and firmware, so it was never stable.

The problem is that I can't even reproduce this error consistently at all for RMA to be submitted, as it happens randomly. To eliminate any possibility of conflicting software, I did countless of full clean OS installs and only installed drivers and Steam to test games. 


  • CPU: i9 13900ks (running stock)
  • MB : ROG STRIX Maximus z790 HERO
  • RAM: Corsair 32GB KIT DDR5 7200MHz CL34
  • GPU: STRIX 4090
  • SSD: M2 WD Black sn850x 2TB
  • PSU: Silverstone HELA 1200R Platinum
  • Cooling: Corsair iCue Capellix h150i Elite
  • OS: WIN 11

Does it look like a faulty hardware behavior? Can it somehow be related to PSU or CPU or compatibility of any of the parts with Maximus z790 HERO? Is it Windows updates messing up something? I would really appreciate any ideas or suggestions as all this is driving me crazy, especially after spending so much money not being able to enjoy it fully 😞


Accepted Solutions

Tested both sets of RAM within OS and Corsair 7200mhz that showed no errors in memtest86 with and without XMP actually showed 100k+ errors. Tested 4th RAM kit that is working stable now (Kingston Fury 6000mhz) and it shows no errors and system is finally working stable now. Just to doublecheck everything, I've put old CPU with Kingston kit and immediately crashing everywhere. So I think it's safe to say that issue was in CPU AND RAM.

Both Corsair and Kingston have Hynix chips, could stability issues be due to higher frequencies? 

View solution in original post


Super Moderator


C5 is often memory or CPU related.

Have you tried reseating the CPU?

Does Memtest86+ pass [with two modules installed and no XMP/Overclocking]? (UEFI Tools Menu).

Remove the CPU and check for any bent socket pins, remount the cooler and ensure even mounting pressure.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Reseated CPU, checked for bent pins on MB - found none. Cooling block was definitely not overtightened. Ran MemTest with both ram sticks without XMP - Passed. Still no effect. I've ordered another motherboard from different manufacturer to test..

Ok, so you've reseated the CPU but have you soak-tested the system to see if it's crashing after doing so?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

It's weird but it never crashed for me in benchmarks or stress tests. After I reseated CPU I ran Cinebench twice without crashes. Apps and games still crash randomly though. Will try same config on another motherboard. If same thing is happening on different motherboard..

Set SVID behaviour to worst case scenario and see if that alleviates the crashing.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Tried another motherboard from Aorus, same thing happening. Running full stock, latest bios/drivers/clean system, no OC, XMP off - still random crashes with access violation and I can't even complete Cinebench now. At this point the only thing is it's either CPU (maybe bad memory controller?) or OS/Software issue (unlikely as someone else would have this issue). I'm just lost now. I guess will try to RMA the CPU..

Yes sounds like the CPU is defective. That’s why I asked you to try the above.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Ordered another 13900KS. Will report back the results. Fingers crossed

Level 7


I have exactly the same problem since I built my PC last November. I've also done everything you said and nothing works, I'm dismayed. The applications close completely randomly with the same error code in the event viewer.

OS, BIOS and drivers up to date.
RAM tested without problems.
Tested with and without XMP profile.
Tested with and without DEP.
Etc etc... like everything else you've done.

Nothing solves this problem.

The applications I use most often that close randomly are :

  • Rocket League
  • Battle Of Sea (Unity3D game)
  • Discord
  • Google Chrome
  • Visual Studio
  • Unity

I look forward to hearing from you with the processor change.


  • CPU: i9 13900k
  • MB : ROG STRIX Maximus z790 HERO
  • RAM: G.Skill Trident Z5 Neo RGB 64 Go 2 x 32 Go DDR5 6000MHz CL32
  • GPU: STRIX 4090
  • SSD: M2 WD Black sn850x 4TB
  • PSU: SEASONIC - Prime Titanium - 1300W
  • Cooling: ARCTIC Liquid Freezer II 360 A-RGB
  • OS: WIN 11