cancel
Showing results for 
Search instead for 
Did you mean: 

z790 Hero - Usb disconnecting

GGiuliano93
Level 8
Hello, i have an z790 Hero with i9 13900k, 3090ti and ddr5 7200mt/s from gskill, using a corsair 7000x case.

Issue number one: when i plug an external hard drive / or a usb 3 stick on the front panels (didn't try in the rear usb on the motherboard) my wireless keyboard works intermittley (HP OMEN SPACER).
Issue number two: Randomly my usb (mouse, etc) keep disconnecting/reconnecting for 1-2 seconds, it happened like 2-3 times in a month.

What can be? I have the latest bios from asus page 0703. It can be a bios setting? Or my mb is faulty? :S

I have connected those usb:

Razer Viper 8kHZ Mouse
Hp omen spacer Keyboard (wireless with dongle)
Astro a40 Mixamp (USB Headphones)

And nothing else.

Thank you.
11,794 Views
21 REPLIES 21

DragDay7
Level 9
Don't trust Armoury Crate, Windows or any app if you do to install drivers for you. Download chipset drivers from Asus website and install it by yourself. They might be hidden under "Expand All" button.

DragDay7 wrote:
Don't trust Armoury Crate, Windows or any app if you do to install drivers for you. Download chipset drivers from Asus website and install it by yourself. They might be hidden under "Expand All" button.


I don't have armoury crate, i download manually drivers from the asus website, i always check.
Also when installed windows i configured offline installing drivers manually, so windows update doesn't interfere.

Edit: I tried to use an usb c hub on the front panel and connected the dongle, if i connect the external hard drive it works flawlessly 🤔

DragDay7
Level 9
Great, that's the spirit. Have you tried disabling usb legacy mode and xhci? My usb devices tent to affect PC if those are enabled.

ahfoo
Level 13
Most likely your system controller driver issue. You may want to search the forum and lookup for fellow member MoKiChU thread for all the driver you need for your system. Hope that help you.

GGiuliano93
Level 8
Well, it was the motherboard that was defective 😕 usb was disconnecting even on bios, sent to the dealer, he tested and sent to asus for rma. I paid 830€, ridicolous to have this problems… 0 control quality. Not sure if my next rig will be powered by asus.

GGiuliano93
Level 8
Bought a z790 apex, i have the same problem... what it can be? I am going insane...

GiulianoTakasu wrote:
Bought a z790 apex, i have the same problem... what it can be? I am going insane...


I believe this problem might actually be Windows 11 related. I have had the same issue on my previous ASUS Maximus X Hero Board with a Z370 chipset and the issue prevails on my new ASUS ROG STRIX Z790-E GAMING WIFI board.

I was able to get rid of the problem on my old Hero board by disabling Microsoft's Gaming Input device service in Windows 11 version 21/H2 but this is no longer an option in the latest Windows 11 22/H2.

Unfortunately, you can not disable the Text Input Management Service in Windows 11 22/H2. I'm almost sure that the issue would be gone if that service could be turned off.

I have tried all other Windows-related solutions like the USB power management settings etc. (I have not tried disabling Legacy and XHCI though so that will be the next step).
The issue happens rarely to me and so far mostly, or even exclusively, when I watch videos (especially YouTube). It has never happened when I was gaming or just using the PC regularly for surfing etc.

This, in addition to the fact that it occurred on my previous board as well, leads me to believe that it is definitely not a hardware issue on the mainboard USB port side. It is either software (Windows 11) or maybe even one of the input devices that is slightly wonky or does not cooperate well with Win 11.
I use a Logitech G Pro wireless mouse and a Logitech G815 wired keyboard as well as an Astro A50 headset with its base station.

In terms of troubleshooting, it is definitely annoying that you can no longer separately disable the Gaming Input service or the entire Text Input Management service of Windows 11.
I do not need that service. I use a keyboard and not a touch device or a pen or anything. Microsoft have made their keylogger an inseparable and uninstallable part of the system in 22/H2. This might be our problem...

My Z790HERO TYPEC front also has this problem. Every time I insert the device, it will be powered off and restarted~

JohnAb
Level 17
I have had these keyboard/mouse disconnect issues three times now.

Once it was a an external NVME drive which has become corrupted (but all was well after reformatting) and just yesterday, I had the same problems with an external hard drive. It was causing all sorts of keyboard/mouse problems but other external drives were still OK. I tried to reformat, removed BitLocker and set up new partitions but it was still flaky. I even tried a spare enclosure to eliminate the SATA to USB interface but no joy. It's now in the bin and my keyboard/mouse are working perfectly again. The drive was 8-10 years old, so I guess these things happen. Annoying as I had to restore 4TB of lost files. The disconnects were happening a lot and then sometimes only once a day. Anyway, no doubt it was the drive.

I'm just mentioning this as another potential cause for such issues. By the way, in both cases Windows scanned the drives and said they were OK.

The other thing I had was a faulty USB cable causing the same issues. Took me ages to work that one out!
Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware 16.1.30.2330, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.