cancel
Showing results for 
Search instead for 
Did you mean: 

Z790 Hero not running GPU as PCIE 4.0 X16 but 3.0 instead

Raigoz
Level 7
So got a new build with Z790 Hero paired with a 13700k and GTX 3080 12GB and I noticed with GPUz it says gpu supports up to PCIE x16 4.0 but its running at x16 3.0.

I went into the bios and selected Gen 4 on PCIE but no change gpu is in the top socket on the board.

Any suggestions would be appreciated.
1,016 Views
25 REPLIES 25

no second slot is empty ofcourse. ialso. removed the m2 and used extenral samsung ssd to see if m2 was causing it but no still x8... i read somewhere that might be ram related aswell? but i doubt it ... btw i used grizzly frame on cpu and ekwb delta tec 2...but i dont think thats what causing it..i mean before it was x16 3.0 at least but still not 4.0 .anyway i hope i find the issue and ill write back...

 

ps i saw alot of people with similar issue with same mobo but they never said what they did to fix it. maybe the cpu is the problem? but how only issue i had is this pcie issue.

and question when clearing cmos i just press the back of the mobo, not removing the mobo battery or anything right? what u suggest

Nate152
Moderator

To clear the cmos, shut down your pc and let the psu switch on.

Press and hold the clear cmos button (marked red) for 3 seconds.

Z790 Hero Clear cmos.png

 

 

 

it was the gpu rog strix 4090...i changed to 14900k and new mobo aswell and still x8

kampers
Level 8

Are you used contact frames? Did you have checked pin in your socket. One guys have a  bend pin in socket so he gets problem with gpu speed. 

Henry1987
Level 7

I had the same issue with my Z790 Hero. What I did not know is that the board has a alternative PCIe Mode switch (manual page 32), it can control PCIE or fan speed and mine was set to step 2 by default (Gen 3 speed). This locks the PCIE speed and it doesn't matter what you set it as in bios.

Yeah I know about this switch on the motherboard. Still if you put a drive in the top slot the graphics card still only shows as Gen 3, moving all the drives to the other slots and the Hyercard sorted it straight away. Not sure if there is that much difference between it being on Gen3 to Gen4 as personally didn’t notice a difference on games but I’m sure there is but 3DMark tests were great on both

pcgamersz
Level 8

it was the gpu..dont read stuff online its not ur cpu or ur motherboard...it was my strix 4090 rog oc

I have the ROG 4090 and Z790 motherboard and by moving the SSD away from the top slot and selecting the switch at the bottom left of the motherboard to Gen 4 mine runs at 16x4

i have the ssd on top slot..i tried another 4090 and boom x16 4.0 it was the graphics card the problem