Showing results for 
Search instead for 
Did you mean: 

Z790 Hero Front Panel USB-C connector does "one time" disconnect when new USB device is plugged in

Level 7

Each time I plug a USB-C device into the front USB-C port (U32G2X2_C9), the following happens:
- The device briefly "connects" and appears in Explorer (followed by the typical Windows "plug in hardware" chime).
- Then it immediately ejects and reconnects, and then is ready for use
So every time there is this "one time" process of connecting/(forced) ejecting/connecting at initialization.
Oddly enough, I don't have this problem with the "rear" USB-C ports, only the front USB-C port.

Note: I used a USB-C connector cable and a USB-C drive that works on another computer with the front USB-C port. So I can rule out that it is a problem with the cable or with the device I used.

The following things I have tried so far:
- Installed fresh Windows 10 on separate partition -> no difference
- I disabled Thunderbolt support in BIOS -> no difference
- disabled USB legacy support -> no difference.
- unplugged the 12V PD connector -> no difference.
- When I plug in a USB-C hub into the front port and then plug devices into the hub, they all work fine from the get-go and there are no one time-disconnects (since the hub has already connected, I guess). So I think that something happens upon initialization (switching data transfer or fast charge modes or something)

I just want to make sure if this is an "intentional" behavior or design flaw / faulty port or a driver / software bug.

It would be helpful if I could get feedback from other Z790 Hero owners if they observe the same behavior with the front port. Thanks in advance for your help.


CPU: Intel Core I9-13900K
GPU: GIGABYTE GeForce RTX 4090 Aero OC 24G
RAM: Kingston FURY Beast DDR5 64GB (2x32GB) 5600MT/s
PSU: be quiet! Dark Power 13 1000W
CASE: BeQuiet! Dark Base Pro 900 Silver rev. 2
Windows 11 Pro 22H2 (22621.1702)


Level 7

I've been having similar issues except it is with the motherboard's IO back panel. The 2 USB-C ports refuse to work but the Thunderbolt port works without an issue. When I connect my S22 Ultra, I can view all of the files on it and even copy files off of it to my desktop. It's only when I attempt to place files on my S22 Ultra from my desktop, is when the phone disconnects itself after copying 1 or 3 from a folder of photos I am testing with.

I have also tested this with a portable SSD with a USB-C connection. It has a different result than my phone, but the result is the same in either port. It seems to disconnect itself at random. I'm still able to copy files to and from the drive. But the disconnect and reconnection is entirely random.

Also, when I have this drive connected, I am completely unable to enter the BIOS. I hit F2 or Del when the screen prompts me to, and the screen just goes completely black, no matter how long I wait. When I remove the drive, I'm able to get to the BIOS normally. 

I know all these devices have worked before as I had an ROG Strix Z690-F motherboard and both devices on USB-C had no disconnection issues.

Here are the things that I have tried:

  • Reflashing the BIOS
  • Using different USB-C cords
  • Switching between the 2 USB-C ports
  • Reinstalling all drivers from the ASUS Drivers & Firmware page
  • Starting on a fresh Windows 11 install
  • I've attempted the BIOS changes you have made with, and I also could not get it to work

I recently bought a USB-C docking station that I have for my work MacBook. Specifically, the ZMUIPNG 14 in 1 USB C Hub. Just like you, I had no issues with my S22 Ultra, or my portable SSD when connecting the USB-C hub to the motherboard and connecting my devices to the hub. I guess I will be using this as a workaround for now. But there is definitely some kind of software controller issue happening here.


CPU: Intel Core I9-13900K
GPU: MSI RTX 3090 TI Suprim X
RAM: G.Skill Trident Z5 RGB Series (Intel XMP) 64GB (2 x 32GB) 288-Pin SDRAM DDR5 6400 CL32-39-39-102 1.40V Dual Channel
PSU: EVGA SuperNOVA 1300 G2 80+ GOLD, 1300W
Microsoft Windows 11 Professional (x64) Build 22621.1702 (22H2)

Level 12

Could it have anything to do with this?

  • USB 3.1 Type C Gen. 2 and USB quick charging option
Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

Level 7


Your problem is interesting. Fortunately, I haven't had any random disconnects after the connection is successfully established (I have only this first time hiccup).


I suspected that too, so I even tried unplugging the optional 12V PD connector to see if that made a difference. But it didn't.

Do you have similar behavior with the front usb-c on your Z790 or does it work normally?

Currently, my Z790 is not in a case with a front USB c connection.

A Z590 Hero does but I have not noticed that behavior on it.

Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

Level 7

Hey, i have the same problem with X670E Asus Rog, you have a solution ?

It is interesting that the AMD chipset seems to be affected as well. But unfortunately I don't have an update on that. The problem still persists to this day.