Showing results for 
Search instead for 
Did you mean: 

z790-e LAN stopped working

Level 8

Build has been running for 2 months.

Initially had issues getting LAN to work, had to turn off power cycling features, turn off wifi in bios and also upgrade my OS to win 11s to finally get it stabilized.

Has been working without issue until Thursday.  Now it just drops/doesn't work

I have been able to make it work by updating advanced settings from auto config for speed and limiting LAN speed to 100 mbit but this is not a viable long term solution.

How issue presents itself:

- PC will be online and watching video/playing a video game and will instantly go offline and no longer recognize the network it is plugged into. 
- Any attempts to restart the network connection (win problem solving step 1) results in a blue screen
- Any attempts at a power down or a reboot results a system hang and forces hard power cycling
- Switching the speed of the LAN adapter causes device manager to crash, but the update goes through and is visible when restarting device manager
- Reboot after changing speed still requires hard power cycle.
- Once started, network functions again, but with limited speed available

Things I have tried

- Completely uninstalled all drivers for LAN
- Reinstalled only Intel sources drivers (issues remains exactly same)
- Completely uninstalled all drivers for LAN
- Reinstalled only ASUS sourced drivers from Amory Crate
- Changed Network cord and validate both new and old cord worked without issue on aux pc network adaptor
- Restarted MESH network multiple times and upgrade mesh network firm ware
- Currently at wits end and DL updated BIOS and a shot in the dark

Not that it matters but it is 13900k processor, 4090 gpu and 64g (2 - 32g sticks)


Level 8

Well after a long painful day I am 100% certain I have had a hardware failure.  I formatted my main drive and did a  completely fresh install to make sure there were no driver conflicts and the problem remained.