Showing results for 
Search instead for 
Did you mean: 

Z790 1402 BIOS

Level 9

Any thoughts on latest Z790 BIOS 1402? 


Level 10

Dont install the Acronis in Windows.  last time i install acronis.  I measure my write speed.  It was 10-15% slower.  Even if Acronis isnt running.  Something was going on in the background.  Build a USB boot media for Acrnois, then uninstall it.   when you need to backup or restore, run it off from the USB.

Level 8

Using my same manual settings as with 1303, my system will no longer go over 5000mhz under an all core load synthetic benchmark. My Cinebench R23 score went from 42-43k down to 35k. I flashed back to 1303 and it still does the same thing. Same result on the beta.. getting stressed. Could this be from changing the CPU microcode and Intel ME?
APEX z790, 107sp 13900KS, GSKILL 7600, NZXT Kraken Elite 360 AIO at 24c liquid temp right now.

I had the same problem in version 1402, if the CPU was fully utilized the core frequencies were maximum 4400 Mhz. It was because the microcode very undervolted individual cores to a maximum of about 1V instead of 1.2V. After switching to beta version 1501 I have a stable system and the performance returned to the original values as in 1303.

I have similar issue after updating from 1303 to 1402. BIOS 1402 with the same settings sets a bit lower power limit for E-cores by -5 Watts and it result -100Mhz on all E-cores, it's below stock clock.

I will wait for official 1501 version before flashing again. I don't really want to to rollback to 1303 due to updated Intel ME firmware, I'm not sure if they are fully compatible. I might have other issue after downgrade.

Level 8

After this update, issues I had sporadically having with blue screens were removed completely. Since I bought this motherboard, I believe that this version of the BIOS has provided me with more stability.

Level 8

It has only been a day since my 1402 fiasco ... but so far 1501 beta has been amazing.  No issues, overclocking seems ok.  I like it

Level 9

I was using 1402 and moved to 14900k CPU but my system was unstable, crashing with any CPU stress test and any game reaching 100% cpu usage. Now I am using 1501 beta and I hope stability come back.

So a friend of mine did the mistake we all did at some point and updated to 1402. Now sometimes the Boot LED lights up and the PC is stuck at the ASUS Logo with press DEL to enter Bios. Mouse and keyboard do not accept inputs but the RGBs are working and reaacting to pressure (color changes) . After several reboots (and sometimes cold boots) the system boots up normally. Since I built the system I am quite sure there is no hardware fail. We tried several M2, different slots and an old 64 GB SSD with Windows 7 on it. Alle the same result. Sometimes the PC got stuck at the Asus Screen with Boot device LED lighing up. 

Level 9

Sometimes like today my mobo asus hero z790 didn't post (mouse and keyboard do not accept inputs), most of the time does now i wonder if this bios is the culprit,

Level 9

New BIOS out!