cancel
Showing results for 
Search instead for 
Did you mean: 

Z690-G Gaming Wifi - black screen / wont boot.

jolly2
Level 7

Hi, 

I've been having problems with my z690-g gaming wifi, it's been occasionally not displaying anything at startup, and now it doesnt seem to want to boot at all.

It'll display a green LED, and do a single beep.  It's been working fine for the last several months.

I've swapped out:

Memory, PSU, GPU - tried using the onboard.  

164 Views
3 REPLIES 3

JohnAb
Level 17

Have you tried a complete power off at the PSU? I had a strange problem the other day and that fixed it. Also try removing the battery for a while if that doesn't help after cutting power.  

MEI, ME and BIOS up to date? Could the CPU be too tight, dirt under it?

Z690 Hero, 12900K, BIOS 3501, MEI 2406.5.5.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Silent_Scone
Super Moderator

Hi @jolly2 

Possibly a handoff issue? Have you tried making sure the monitor is powered on prior to switching on the system?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Not a handoff issue, I've tried with different monitors/other systems, and there's no reason it would start having issues recently.  

Bios is 3401.  The release notes claim it updates the ME simultaneously.  I've tried complete power off, have not tried pulling the battery. I don't see any easy way to get to the battery.  

 

Would be surprised if CPU install was too tight - I used a     0.60 n-m driver.