Showing results for 
Search instead for 
Did you mean: 

Unable to Install Intell Management Engine Components (Fatal Error)

Level 7


I just updated my board's bios and Intel ME firmware. However, when I try to run the setup utility to install the latest Intel Manage Engine Components update I am having the installer exit on fatal error. I've tried redownloading in case the copy I received was corrupted somehow but it doesn't change any results. I am running Windows 11 with a Z690-E Gaming and i13900K.


Level 16

Have you tried running the installer as admin? That might help. You could also try MokiChu's MEI drivers from his threads and you'll find the latest version there too - 2251.4.2.0.

The MEI drivers will be the same, but you can try using 'install.cmd' in his driver packs rather than the default setup files on the support pages (SetupME.exe). 

Z690 Hero, BIOS 2703, MEI 2316.5.0.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 22H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.