Showing results for 
Search instead for 
Did you mean: 

TUF Z790-P Wifi D4 - A1&A2 Ram Slots Not Working After New GPU

Level 9

Hello there. After 6 years with ram nightmare MSI-Ryzen, I built a new PC with Asus-Intel. But i woke up to the same nightmare 😞

So i built this 10 days ago without 4070 ti. Everything worked fine. Rams were at 3600Mhz with XMP profile. No errors, fast boot. But yesterday i got my new 4070ti. I plugged it in and pushed the power button. Fans went turbo, it showed short red cpu led then long orange dram led, frequently repeating it.

I just installed a GPU.

So i tried with one stick on every slot. Slots B1-B2 are working but if i put anything to A1-A2 it never post. I can't use dual channel.

What i've tried;

- Updated bios to 0810
- Tested with old GPU

- Tested with old working 3200mhz 8gb ram sticks (x4)

- Removed Battery

- Reseated CPU Cooler

Nothing worked.

Also i'm experiencing severe audio popping with my Anker Soundcore Q35 bluetooth headset. I'm using mobo's bluetooth to connect, it worked fine before. Now it's another nightmare.
Any help will appreciated, thanks!

Here is my build:

CPU: Intel 13600K
Cooler: IDCooling SE-225-XT (2 Fan Tower)
MOBO: TUF Z790-P Wifi D4

GPU: Zotac RTX 4070 Ti
Ram: 4 x 16Gb Corsair Vengeance LPX 3600Mhz (2 x Dual)
PSU: Thermaltake Toughpower GF1 850W Gold


Level 9

Anyone? 😞

Hello kutay-akyurek

So, all was fine until you installed your RTX 4070ti.

Are you using the adapter cable? 

Make sure you are using two separate 8-pin pcie power cables (not one cable with two connectors). Check the pcie cables are connected to the correct psu power ports.

Have you tried reseating the gpu and resetting the bios to defaults? (F5 key)

Yes i just installed the GPU and then slots were gone.

For the GPU i use Zotac's cable. 2 sepereate 8 pins coming from PSU to this 2x8pin to 16pin cable, then the GPU. That 16 pin sockets are smaller then PSU's.

And yes i reseated GPU 3-4 times and reset bios to default by both removing battery and from bios.

I don't have time to send it to a service, i have a lot of work to do in premiere pro 😞

Level 16

You could try updating the 'DisplayID' via the Nvidia tool. See this video:


Z690 Hero, BIOS 2703, MEI 2316.5.0.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 22H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.
Learn more about the All New NZXT H1 2022 at Get your JayzTwoCents Merch Here! - ○○○○○○ Items featured in this video available at Amazon ○○○○○○ ► Amazon US - ► Amazon UK - ► Amazon Canada - ...

I tried updating display id but it says no compatible devices found.

Also i changed all power cables with new ones. Still no post with rams on slots A1-A2. After i remove those 2 sticks, it posts immediately and i can enable xmp to 3600mhz with no problem at all.

However, after i reseated GPU i wanted to reseat the CPU and cooler too. After removing cooler and cpu i saw this (uploaded screenshot)

I have no idea what happened. I put CPU and cooler 20 days ago one and only time and never touched it again. This is the first time i remove the CPU since i built the rig. I really don't know whats happening here :S

I didn't touch the socket, what should i do now?


Are we meant to see something in the attached image? I'ts out of focus so unable to see if there is any damage to the pin pad.

Dropping memory slots is usually a sign of inproper CPU pin pad pressure so you were right to try and remove it. Moreover, it is not recommended to combine memory kits.

Make sure motherboard stand-off screws are not over-torqued in the DRAM and CPU area.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

There was a tiny dust ball on center right, i removed it but problem continues.

Still everything is running perfect except A1-A2 slots. I can enable XMP without a single issue as soon as i remove other 2 sticks on A1-A2. First i get a very short red CPU led, then Dram led is orange all the time when 4 sticks loaded.

I upgraded my rig because i wanted more smooth workflow in Premiere Pro. Upgrading 32gb to 64gb was the primary thing along with 4070 ti. Now it's slower than before, and have a tons of work to do. Idk what to do right now.

Level 16

On the image, it looks to me like there might be a damaged pin on the right hand side of the socket. Hard to tell, so have a very careful look. If there is a bent pin, you might be able to bend it back, but be VERY careful. Some people have corrected bad pins successfully. Also make sure there is no dirt, hairs, or other debris between the CPU and socket. One of those 'clean air' spray cans might help before re-mounting the CPU and don't over-tighten the cooler. Good luck. 

Z690 Hero, BIOS 2703, MEI 2316.5.0.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 22H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

I looked it with magnifying glass, there is no bent on pins. I'll look for stand-offs. Thanks.