Showing results for 
Search instead for 
Did you mean: 

Tuf Gaming z790-Plus Wifi severe issues

Level 7

im having issues with my tuf gaming z790-plus for over 3 months now and cant seem to solve them.
The main Issues are:

- pc is having application errors resulting in them vanishing.
- BSODs with mainly SYSTEM_SERVICE_EXCEPTION with win32kbase.sys
- constant WHEA-LOGGER warning Event-id 2 where it says hardware malfunction corrected

I have tried to solve this with the process of elimination.
RAM: ive tested with windows memory diagnostic & over 8h Memtest86
CPU: with stress testing it with prime95 & Intel Processor Diagnostic Tool
SSD: chkdsk & useing different slots and different units
GPU: i fresh installed win11 without external gpu
PSU: switch for another one

All of this didn't solve my problems. i also updated the bios and intel me.
Which leaves me to believe something is faulty with my Mainboard.
I've already send the Mainboard to Asus for repairs which came back with the message they could not comprehend my Problem.

My Components:
CPU: Intel i9 13900k
PSU: 1000W
GPU: nvidia rtx 4080
RAM: 2x16GB Kingston KF560C36BBEK2-32
SSD: Samsung SSD 980 1TB / Samsung SSD 960 EVO 500GB


Level 7

Same exact problem, my computer is brand new from 2 weeks ago. 64gb ddr5 and nothing fixes the prob, not even bios update ou Intel me update. I tested all components in another setup. 


I don't know what more I can do and Asus does not acknowledge the problem. 

Level 16

Guys - check the following and see if it helps:

Disable PCI Express Native Power Mgt in BIOS (advanced tab, platform misc configuration)
Disable Native ASPM (Active State Power Management) (advanced tab, platform misc configuration)
Check that power savings in Link State Power Management in Windows (Edit Power Plan/ Advanced settings/ PCI Express/ Link State Power Management) is not set to maximum. Moderate should be OK.

Not sure about the BSODs, but may fix the WHEA errors. 

Z690 Hero, BIOS 2802, MEI 2336.5.2.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

unfortunately it didnt help me i still get whea errors and application errors.
something interesting i've observed is that when i stress the system with for example prime95 it stays stable for some time and after stoping prime95 everything goes down the drain. i get about about 4 whea errors per second and every program ends with an application error which also can accumulate into an bsod. (also windows explorer and taskmanager)

Super Moderator


1. Memtest86 may not pick up all memory instability. Can you use OCCT memory stress test or Karhu Ramtest?
2. Disabling XMP?
3. One memory module in slot A2
4. Reseat the CPU, check the CPU pin pad and then reapply cooler whilst checking for even mounting pressure.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 7


1. did occt for 25 min which then resulted into bsod. cant start occt anymore which results into app error or bsod
2. & 3. yes tried different xmps/no xmp. different singular sticks.
4. seems so sit right & also cooling seems ok. (prime95 70c)

i ordered new ram and will test if that helps.

Found my issue. I was a noon and I should have known that ddr5 compatibility is still an issue. 

For the Asus tuf z790 wifi plus, the compatible ddr5 list is available of product page of Asus website under Support then Memory. Turns out it's pretty limited, for Corsair Vengeance 16gb 5600mhz, turns out that I can only use 2. If I use 4, the system is unstable. 2 x 32 gb is fine but not 4 x 16gb. Brands, models, sizes and speeds that are compatible are all listed.

I'm disappointed to say the least because I can't return my memory to buy 2 x 32gb that is compatible. 

Level 9

A familiar problem, I found a solution for it In BIOS in the CPU menu the options


Intel speed shift technology

intel speed step

After that all the log errors will disappear After that in the temporary folder in Windows It is not full of error files


asus prime z690 d4. i7 12700k. ASUS TUF OC 3080TI.

Level 7

I've switched some components around and learned that the cpu/mainboard are the problem. the old cpu didnt work on both old and new mainboard. my new cpu worked on the new mainboard but on the old it also showed errors. ram worked the same on both mbs.