Showing results for 
Search instead for 
Did you mean: 

TUF Gaming Z790-Plus Wifi D4 red Q-LED issue

Level 7

Hello there! This is my first post here, but here it goes: I'm building my first PC and when booting for the first time, I updated the BIOS to the latest version, but every time I power up the PC the red Q-LED (CPU) stays on, but the weird part is that there's sometimes I can use Windows without issues. I checked the CPU, reseated, broken pins, everything, but nothing, again, I can use Windows and even check the CPU's info.

Fans and AIO are working just fine, memory is working fine too, also checked the PSU, but nothing.

Maybe I need to apply warranty and change my mobo??

What else can I do?

Thanks in advance for the help


Super Moderator

Welcome 🙂

1) Can you confirm if the behaviour occurs at complete defaults?

2) Try also reseating the DRAM

3) Try clearing the CMOS by using the Clear CMOS header (#13)



13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

1) I can confirm it even happens with defaults.

2) Already tried, same result.

3) It only boots directly into the BIOS.

I'm adding extra info:

CPU: Intel Core i7-13700K



1 TB NVMe 

I can see all the system's info in BIOS (specifications, temps, voltages), I don't know at this point if the CPU could be causing issues, I don't have another PC to test the processor and the rest of components.

I'll attach an image with the screen I  get every time I boot. (BIOS version 1002)



So resetting the CMOS allows you to boot into the BIOS - what behaviour is exhibited when you attempt to boot into the OS?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

It just shuts down, then powers up, but the Q-LED (CPU) remains on, sometimes I can get into the BIOS, sometimes not. 

I can't boot Windows now, it seems that not restarting has causes the OS to not boot (a blue screen appears).

I reseated the CPU again, and after powering up, I got a message telling me that the mobo detected a new CPU, so that can discard the CPU as the root cause.

At this point, I've tried almost everything, I could try with another CPU, but I don't have friends with compatible CPUs.

It depends what’s causing the stop code. Are you able to capture what it is or enter boot recovery mode? Windows should enter this automatically after a few attempts.

Can you confirm you are not enabling XMP profiles, also.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Yep, no XMP profiles active.

On Windows I get the invalid boot device message, but that's because I still have issues figuring out why it can't boot normally.

Level 7

Quick update: I'm able to enter Windows 11 at times, it's just the randomness of being able to boot to Windows that still is making me wonder what's going on.


This was an issue with a particular version of Intel’s chipset driver (v10.1.19222.8341) when paired with 13th gen CPUs where after a subsistent reboot the system would halt on that stop code. Perhaps make sure you’re not using that version and attempt to rollback/reinstall.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I checked and I don't have that version of the controller, also, I still have the red Q-LED issue, is there any specific test I need to perform to finally solve this issue??