cancel
Showing results for 
Search instead for 
Did you mean: 

TUF GAMING Z690-PLUS WIFI D4 boot problem

EndBase
Level 7
Hi,

I recently bought the ARC A770 16Gb graphics card and that has lead to booting problems.

It's like from a cold boot I have to reset 2 times before it boots into windows. rebooting works normal btw

I have IGPU connected to one monitor with DP cable and the other monitor connected to the ARC graphics card same with DP cable

I know that I have to set in the bios the primair boot on PEG and multiple monitor on disabled but it keeps switching back to IGPU settings

Any suggetions on this problem?
735 Views
3 REPLIES 3

lalantha
Level 9
I don't know much about these cards. But I saw a review from Gamers Nexus, and he said that those cards have known issues on drivers and monitors not picking up the signal sometimes.

Edit: But I am not sure any of above is related to your problem. When you say switching back to IGPU settings, does it display from the IGPU? Or is it just a black screen?

lalantha wrote:
I don't know much about these cards. But I saw a review from Gamers Nexus, and he said that those cards have known issues on drivers and monitors not picking up the signal sometimes.


Yeah I did some reading before I got the card it's well known information but I'm looking for a solution towards my situation thx for the reply

Edit: It just hangs on booting the light on motherboard gives green but it gives no display or boot image and hangs

EndBase
Level 7
Found the problem actualy secure boot in the bios was by default other OS and I changed that to Windows UEFI Mode and custom on Secure Boot Mode had to install the default securitie keys and now it boots in one go from a cold boot