cancel
Showing results for 
Search instead for 
Did you mean: 

Thunderbolt not working after bios update (ProArt Z690-Creator Wifi)

ninbura
Level 7

I'm having the same issue as are many others, where after updating my bios on my ProArt Z690-Creator Wifi my Thunderbolt is no longer working with my professional audio interface (RME UFX+).

Could we please get a real solution to this problem? I tried everything mentioned in the linked post and nothing works... There was mention of a "bridge" BIOS version but it was never made public. It's very unprofessional of Asus to be aware of many professional users having problems connecting professional gear to their "professional motherboards" & do nothing about it. There seems to be so little interest in fixing this issue that you've locked the previous thread so people can't continue to report that it's not working 🙄

bios - 2602
me - 16.1.27.2176

1,097 Views
1 ACCEPTED SOLUTION

Accepted Solutions

yangning8109
Level 9

Thunderbolt 2 is no longer supported by new BIOS (thunderbolt firmware NVM 36).

View solution in original post

3 REPLIES 3

yangning8109
Level 9

Thunderbolt 2 is no longer supported by new BIOS (thunderbolt firmware NVM 36).

Nate152
Moderator

Hello ninbura

The easy solution might be to roll back to bios version 2403 or 2305.

ninbura
Level 7

Interesting, so it's not necessarily and ASUS problem? I assumed that Thunderbolt 2 via a Thunderbolt 3 adapter was just recognized as Thunderbolt 3. Dang... guess it's really the interface that's the problem, no way for me to upgrade that.

Luckily it can run over USB 3, but with greater delay and worse consistency in my experience. May be time for me to change to a PCIe interface from RME, keep this one just for the physical in/out. Thanks for letting me know, I didn't gather this info in any of the "TB is broken" posts.