cancel
Showing results for 
Search instead for 
Did you mean: 

Sabrent Gen5 2tb M.2 in Dark Hero M2.1 slot only runs at half speed

VK101
Level 7

I have a dark Hero board with a Sabrent m.2 in slot 1 that should produce a speed of close to 14,000 MB/s, however i only achieve 7,800 or so.  I have reviewed the posts and others have had a similar issue, however there is no resolution that i can find.   I have what i believe to be the proper settings in BIOS.  I seem to be getting only Gen 4 rather than Gen 5 speed. Can you help. 

601 Views
18 REPLIES 18

Silent_Scone
Super Moderator

Hi guys,

The drive should be automatically detected @ GEN 5.0.

You may want to ensure you haven't accidentally adjusted the Alt PCI Mode switch.

Silent_Scone_0-1716441281697.png

 

 

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

it looks to be in Auto

IMG_7633.jpeg

i am aaking Sabrent if they have any updates.  last i checked the firmware was updated 

Yes, see what they say. I've not seen too many instances of this drive just yet, and namely the T700 Crucial.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

have you have good reports from the crucial T705?   i think i may substitute that for the sabrent

JohnAb
Level 17

Haven't read all of the posts, but have you tried enabling write caching in Device Manager? That fixed a slow but brand new NVME TB4 external drive for me earlier today. Now I'm at a full 40Gbps. Don't know if that works for internal drives, but I guess it should. Just giving you a potential idea to try...

PS my internal drives have write caching enabled by default, so worth a look. 

 

Z690 Hero, 12900K, BIOS 3603, MEI 2407.6.1.0, ME Firmware 16.1.32.2418, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

John Ab thanks for the idea. i have write cache enabled and still only get gen4 speeds  😞 

extreme
Level 8

Defective it seems or may be try another same spec drive. Might also drive getting hot and throtlling it speed.. check thermal pad

Thank you for this suggestion.  Unfortunately the Dark Hero has only the m.2 1 slot which is gen 5 connected to the CPU. the other gen 5 slots are the GPU slot and the other pci slot.  

 
thank you again and please keep the ideas coming