Showing results for 
Search instead for 
Did you mean: 

ROG STRIX Z790-H yellow/amber post light on mobo - no video also

Level 7

So finally got around to testing the build, and at first there was a faint red light by the 8 pin power connector, which I reseated and then was able to power on properly. It took a few power connector reseats after that to get the case fans to turn on at boot. CPU fans worked from the getgo. GPU card led powers up as does the light in the vrm cover.

Amber light on mobo generally means memory issue. Reseated the RAM a few times in different slots, no diff, tried a different brand of new RAM, same result. Tried the BIOS autoflash thing with a USB, nothing. I'm not seeing anything on my monitor either, which is plugged in via HDMI, tried the HDMI on the mobo and on the vid card, nothing.  There's also no boot beep, but that's because I don't seem to have a case header cable for one to attach to the mobo. 

I even reseated the CPU, even though the light was not red, but yellow, as red indicates CPU issue.

One thing to note - the case is running super cool, like 4-5 degrees below room temp, which would imply that nothing is spinning up to generate heat. Also, when I unplug the power 8 pin for the GPU, it's fans spin up, but when it's in, they do not, but the rgb logo lights up and changes colors. 

I'm starting to suspect that the PSU isn't strong enough, its 700w. Here's the build specs. Next step is calling Asus support. 

Zalman Z1 Case, asus rog strix z790-h mobo, G.SKILL Ripjaws S5 Series 64GB (2 x 32GB) 288-Pin PC RAM DDR5 6000 (PC5 48000), GIGABYTE Gaming OC GeForce RTX 3060 12GB GDDR6 PCI Express 4.0 ATX , Intel Core i7-12700KF - Core i7 12th Gen Alder Lake 12-Core, Thermaltake Smart 700W 80+ White Certified PSU, Western Digital 1TB WD Blue SN580 NVMe Internal Solid State Drive SSD - Gen4 x4 PCIe 16Gb/s, M.2,  Western Digital WD_BLACK 2TB SN770 NVMe Internal Gaming SSD Solid State Drive - Gen4 PCIe, M.2 2280