Showing results for 
Search instead for 
Did you mean: 


Level 8

UPDATED 18/04/2023 SPECS

CPU: i9-13900K
RAM: Trident Z5 RGB DDR5-6400 CL32-39-39-102 1.40V 32GB (2x16GB) Intel XMP
SSD: Seagate FireCuda 530 2TB
PSU: Seasonic Prime PX-1300
Cooler: Lian Li AIO Galahad 240

Hub: Controller Lian li L connect 3 (10x Lian Li SL120 Infinity)
Mouse: Logitech G Pro X Superlight
Keyboard Logitech G915 TKL Lightspeed
Webcam: Logitech Streamcam

This motherboard was replaced via RMA and the problem still persist. The USB seem randomly overcurrent when my iPhone USB-C charger to USB-C (front panel) but didn't happen when its charging to motherboard back of IO (USB-C). Also, The entire USB randomly went to off during iPhone charger to USB-C (Front Panel). Not sure why is that? I just checked the motherboard and looks clean even before and after RMA motherboard. The problem still persist as well just only at USB-C header cable to Front Panel of case.

When I restart my pc with iPhone USB-C charger to Front Panel only. I get USB Overcurrent on the screen and 15 sec to shutdown itself. I've checked USB-C header and there no bent or anything yet. So motherboard problem or somewhat?

I've been tested with other power resupply (PSU) and other PC case. The problem still there.


Level 8

I have the same problem on my z790 e gaming. When there is no device connected on the front usb c, just one cable. And at startup, there is an inscription of the BIOS USB device over current status detected. If you pull the cable out of the port, then everything is ok. But there is another problem, sometimes the mouse or keyboard freezes, it happens together and separately, and sometimes the Internet disappears through the LAN cable. Helps to pull out and insert the cable into the connectors USB and LAN

Level 7

I am having USB problems as well. I cannot use any external capture card - the Elgato S60 and KRATOS THEIA4K is not working for me. I tried literaly everything ... this is the second board - same issue. I don't get this. 

What keyboard and mouse do you have? Are there any problems with them?

I am using Logitech. I have also a Elgato 4K Webcam. All other devices except for the two capture cards are running normal. But I tried several capture cards and tried them on other PCs as well. It’s just on this PC. Reinstalling everything didn’t help as well.  

Level 8


Download PD update tool on ASUS support motherboard website.

Go to ASUS Website Z790-E GAMING WIFI > SUPPORT > DRIVER & TOOLS > BIOS & FIRMWARE > Scroll down 'FIRMWAVE' > Click download on 'PD update tool. 

After that. Please shut down the computer then unplug the PSU for 2min then plug it and turn on the pc as normal. You good now.

So fantastic! I knew it is wasn't my motherboard issue. Good job ASUS did it. 

I managed to find your thread after experiencing this same problem with my exact same motherboard mode. Front USB, plugged in a 65w capable type-c cable into the port, and without even connecting it to an actual device (my phone) immediately usb-c was disabled on my system and the errors popped up about a power surge.

Thought my case was faulty. After a day of googling, the algorithm gave me your post and I saw your solution. Ran the PD Tool as admin, made SURE to shut down the computer & power cycle/drain power, and it booted up and everything seemed to work fine. AsusFCNotification working.

Commenting to boost the thread and help the algorithm for the next poor person experiencing this issue with Asus motherboard.

thank you that fixed the issue for me. went for charging 1 am to 21 amps:) 

on a side not i also had to replace my front panel connector, every time i would wake from sleep with something plugged into the front panel usb-c i would get an error "usb overcurrent detected"