cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Strix Z790-E All USB Ports Stopped Working

Liz
Level 8

Yesterday Keyboard and Mouse simultaneously stopped working. No odd events preceded the stop. I plugged them into other USB ports on the PC with no luck. I tested them both on another PC and both worked fine.

I have tried different kbd and mouse on USB's also without any luck. I have restarted the PC numerous times including unplugging from mains and cannot get USB ports to load.

PC starts fine and loads to the Windows 11 screen as it would usually do.

I would very much appreciate some advice on how I can get into BIOS to see what has happened without the USBs for the kbd and mouse.

Cheers

285 Views
4 REPLIES 4

JohnAb
Level 17

So are your ports working again? I get a similar fault sometimes if I plug in another USB device, but I've never had ports not work after a reboot. If the USB root hubs are managing power, then the sudden surge when plugging in seems to cause instability. The easy fix for USB problems can be to turn off power management for the USB root hubs in device manager.   

JohnAb_0-1700299962954.png

Do you mean that you cannot access the BIOS because the keyboard is not working at all? Other than trying another keyboard and other ports, I'm not sure how to get around that problem. Perhaps you have a problem USB device plugged in? Try unplugging every USB device apart from the keyboard and see if you can identify a device that's causing the problem.  

Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware 16.1.30.2330, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Hi John, Thank you for your reply. I very much appreciate it.

I only have 3 devices using the USBs and have unplugged each and tested. With no luck. None of the USB ports are working.  I actually think that they are no longer registered in the BIOS or something similar. 

Cheers

trihy
Level 9

Unplug 5 minutes from the wall socket and try again.

Liz
Level 8

Hi trihy. Thank you for your response. Have tried unplugging etc several times without success. (sigh).