Showing results for 
Search instead for 
Did you mean: 

ROG Strix Z790 Boot Issues

Level 7


Looking for some help with a new PC I've just built. I had been gaming for a few hours, went to grab a drink, came back and Windows had crashed. It was still on the screen, but couldn't move the mouse etc. Power cycled the machine, all the lights turned on, motherboard graphics card etc. All Fans were spinning but nothing on screen. 

Left it a few minutes, still nothing. Power cycled again. This time when it booted up I got an error that the PC has POSTed in safe mode. Was taken to the BIOS, I reset it back to defaults and power cycled again. Same issue, black screen, power cycle, POSTed safe mode.

So I took the power out and left it for 30 sec, plugged it back in, powered on and this time it booted up to Windows. Restarted WIndows just to make sure everything was alright... I am now back to POSTing in safe mode. Pull plug for 30 sec, Windows boots. Restart or shutdown Windows and the cycle repeats.

Things I have tried:

  • Reinstalling Windows
  • Removing all power cables from motherboard and PSU and reconnecting them
  • Tried a different PSU
  • Reseated RAM sticks
  • Clearing BIOS
  • Downgrading BIOS
  • Removed all cables (USBs, HDMI) except for main screen DisplayPort

The system just does not want to boot unless the power is removed. When I do get booted into Windows, everything seems to be working fine. Can load games OK. Has anyone seen this before or have any other ideas? 


System Spec:

  • Motherboard: ROG STRIX Z790-F GAMING WIFI
  • CPU: Core i7 13700KF
  • RAM: Corsair Vengeance Black 32GB 6400MHz DDR5
  • Cooler: Corsair iCUE H150i RGB ELITE 360mm
  • Storage: 2x WD Black SN850X 1TB M.2 PCIe 4.0
  • PSU: Corsair RMe Series 850 Watt


Hello SolidParadox

"PC has posted in safe mode".

This is a sign of instability and I'll bet it's your memory that's unstable. Make sure you have the memory installed in the A-2 B-2 slots (2nd and 4th slots from the cpu).

Enter the bios, hit the F5 key to reset to defaults, then hit F10 and Enter to save and exit.

It should boot up to windows without issue. If it does, use it like this for a while and see how things go.

After a while....

If all is well, enter the bios and enable X.M.P.. If you start to have issues then you'll need to either raise a few voltages, lower the frequency or loosen the timings to achieve stability.



Hi Nate, 

Thanks for the suggestion - I gave this a try today, with no success! Loaded into BIOS, reset to defaults, saved changes. 

PC rebooted and was stuck on the black screen - Never made it to Windows. I then removed the power, waited 30 sec and everything booted OK! 

I have my RAM in A2 and B2 - I even tried moving them to A1 and B1, same issue.

Have you also tried switching the psu switch off for a few seconds?

When it gets stuck at the black screen on reboot, does any of the motherboard lights stay on?

If so which one?

CPU - Red

Dram - Yellow

VGA - White

Boot Device - Yellow and Green

Turning the PSU switch off gets me the same results as pulling the power out of the wall - The PC boots OK.

So when the PC gets stuck on the black screen the lights I see are:

Red > yellow> then nothing, no lights at all. It never makes it to white or yellow and green




Thank you

I have the ROG Strix Z690-F Gaming Wifi motherboard.

When I boot up, the lights go in this order, Red, Yellow, White, Green. When it turns Green the display comes on.

It seems yours isn't giving the white light which is for the gpu. This could possibly be due to some settings in the bios.

Enter the bios, hit F5 to reset to defaults.

On the Boot tab, Disable CSM (Compatibility Support Module) and set Secure Boot to Other Os.

Check the first boot device is set to your boot drive, it should say "Windows Boot Manager" in front of it. This lets you know you've done a UEFI install.

Any luck booting after trying this?

Looks like the CSM being set to disabled is the default along with secure boot being set to other OS. 

Starting to think there is something wrong with the board now. I have tried a different PSU and GPU, borrowing some DDR5 RAM from a friend to try that but I would be very surprised if I got 2 dud sticks!

Strange one though - Seems to be whenever something tries to gracefully shutdown or restart the system. If I use shutdown, restart or sleep through Windows the system doesn't come back until the power is cut.

Same with the BIOS. If I change a setting in there and it resets to apply the changes, the screen is black until I cut the power. 

Typing this live from 1303 just now - unfortunately it has not sorted my issues


Sorry to hear bios 1303 didn't solve the problem.

When you reboot and get the black screen, try reconnecting your monitor cable. You should get display, the white light on the motherboard should come on and stay on until you reboot.

If that doesn't help, it could be a handshaking issue with your monitor, maybe try a different monitor cable, HDMI, Displayport or another monitor if you have one.