cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX Z690-I GAMING WiFi m.2 Problem

scryed
Level 9
Hi, maybe someone could help with this, totday i build my PC it uses 2 m.2 ssds and 2 sata ssds and the Problem is m.2_2

I have on this Port a pcie3.0x4 ssd installed pny cs3030 2tb but it only uses x2 with this its slower than it could be ......... The m.2_1 is a pcie4.0 x4 and this one works fine....... Sata ssd on the doughter Board are also installed
612 Views
22 REPLIES 22

Adrian1983 wrote:
I've been following this thread a little and I have to say I am confused why people are having such issues, I have the Strix Gaming A which has 4 GEN 4 M2 slots, I have 2x 970 Evo Plus both running at the correct Gen x 4 speed and I also have 2x 980 Pro's Both are running at GEN 4 x 4 I have benchmarked all 4 M2's and all speeds are correct and I also have a 3080 which is running at PCIE 4.0 x16.

I really have no idea what Asus is saying about it sharing with the CPU as my Strix manual does not say that for M2's, Now I find it hard to believe Asus have made more expensive boards with more rubbish storage options than the Strix, Correct me if I am wrong this would be a silly move on Asus's part.

Also just to add I installed all 4 M2's once and they're all working as they should.


Well in stark contrast to the Z690-I, the Z690-A is by far a more simplistic i4 x M.2 design, they are installing flat into the MB directly, piece of cake.

The M.2 problems with the mITX small factor of the Z690-I setup is the space saving fiddley design, whereby the M.2 are stacked vertically, getting all those micro connectors sitting just right when assembling is a tricky feat for even the detailed screwdriver fanatic.

Other than that, everyone's cooking on gas as far as I know.

rob616
Level 7
+1 for this mess. Z690-I, two Samsung 980 Pro 2TB. Top slot (M2_1) works fine. Bottom slot (M2_2) worked at best x1 speed. Removed and re-assembled about a dozen times, tried different combinations of pressing on this side or that side, never got it connect at x4, sometimes it wasn't recognized at all. Crazy that a motherboard this expensive would be so flaky.

I've been having this same issue with 2x 1TB Samsung 980 Pro drives. The upper M.2_1 slot works fine, but in the lower M.2_2 slot the drive is recognized by the BIOS, but not by the OS (tested with both Windows 11 and Ubuntu 21.10). Reseating the drive numerous times has not resolved the issue, nor has trying to manually reduce the speed of the slot to earlier PCIe generations. The BIOS always recognizes the drive as being an x4 device (and will even run SMART tests without error), but the OS fails to read or write to the device. The drive will sometimes show up in the Windows disk manager, but it always fails to partition or format when it does, and it never shows up in the Samsung Magician tool. Interestingly, older Gen 3 drives (e.g. a Samsun 960 Evo) seem to work fine in the M.2_2 slot, so I wonder if the connection is just nominal enough to not properly support the faster Gen 4 PCIe speeds.

I contacted Asus support and after going around in circles a bit (First they tried to get me to install the latest Intel RAID drivers -- I'm not using the drive in RAID mode. Then they wanted me to try the M.2_3 slot, which this board does not have. 😛 ) they agreed to RMA the board. But they don't have any spares in stock at the moment, so I was asked to wait a few weeks and then check in again. Hopefully the replacement board works better, but I'll update here once I have it in hand. It's not clear to me if all the boards have this issue, or if there's some degree of luck to it.