cancel
Showing results for 
Search instead for 
Did you mean: 

ROG STRIX B760-F GAMING WIFI New M.2 drives not working

Langleys
Level 7

12th Gen Intel Core i9-12900k
64GB RAM
NVIDIA GeForce RTX 3090

Sabrent Rocket Q 1TB NVMe PCIe M.2 2280 Internal SSD High Performance Solid State Drive R/W 3200/2000MB/s (SB-RKTQ-1TB) 
- Connected to - M.2_2 slot (Key M), type 2242/2260/2280/22110 (supports PCIe 4.0 x4 )

The above M.2 SSD is where my operating system currently sits, CrystalDiskInfo states its at 49% health,

So I bought a second M.2 drive - Crucial P3 Plus 1TB M.2 PCIe Gen4 NVMe Internal SSD - Up to 5000MB/s - CT1000P3PSSD8 
- Connected it to M.2_3 slot (Key M), type 2242/2260/2280 (supports PCIe 4.0 x4 ). 
this drive did not appear in the BIOS or windows disk management, so since it was in windows disk management I couldn't format it If needed. 

I moved the Crucial P3 Plus 1TB to - M.2_1 slot (Key M), type 2242/2260/2280  (supports PCIe 4.0 x4 mode). - No change whatsoever.

I left it a few weeks , bought another m.2 drive - Crucial P3 2TB M.2 PCIe Gen3 NVMe Internal SSD - Up to 3500MB/s - CT2000P3SSD8 - and connected it to - M.2_3 slot (Key M), type 2242/2260/2280 (supports PCIe 4.0 x4 ). 

Still nothing, I then swapped around the Sabrent m.2 drive and the Crucial P3 2TB drive around to see if it was a motherboard issue, in that instance, the only M.2 drive that could be seen, continued to be the Sabrent one. I then moved the Sabrent M.2 drive to M.2_1 to ensure that one was working, whilst leaving both crucial m.2 drives in M.2_2 and M.2_3. Still nothing

I have tried enabling CSM , it didn't change the fact that I couldn't see the new m.2 drives in the BIOS or in windows disk management.
I updated the BIOS ,
I've reset the BIOS config,
I've cleared CMOS , 
I've updated all of the drivers that the "ARMOURY CRATE" software stated needing updating. 

nothing above has changed it, my Sabrent M.2 drive works in all M.2 motherboard slots, so that proved they are functional, surely two new separate M.2 drives could be defective? after seeing that there was a youtube video made to help users guide through fixing this, I feel like its less likely to be two defective M.2 drives. 

Can anyone assist me please?

1,105 Views
5 REPLIES 5

JohnAb
Level 17

I have come across the M.2_1 slot not working before if the ME firmware has not been updated. That was on 690 boards (with earlier BIOS versions). 

Having said that, your problem is not the same - you have two drives not working. As you say, that does seem unlikely. I don't think there are any BIOS settings to turn the M.2 slots on/off, so can you try those other drives in another PC? Maybe format them and try then try again?

Final thought, is RAID enabled or something? You could also go to MoKiChU's threads here and update the Intel VMD drivers for your board. Not sure if it will help or not, especially as all M.2 slots are functional.  

Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware 16.1.30.2330, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Langleys
Level 7

So I have 3 M.2 slots , my sabrent m.2 drive works in all of them, my other two new ones don't appear in windows or in the bios when I plug them in. So if there were a BIOS setting relating to disabling specific M.2 slots, then the BIOS would need to
1. Find the slot that the Sabrent SSD is connected to
2. Then decide to disable the other two

I think there is a way to disable specific M.2 slots(might be wrong)from memory when I was browsing the BIOS settings however , they are all enabled since the Sabrent one works with all of them. 

+ Nope no RAID, as the only storage solution I had was the M.2 drive, I didn't have any hard drives/SATA ssd's.

Unfortunately the only other PC I have is my laptop, and without extensive unscrewing , it will be difficult to add the nvme drive to that. so I've ordered an NVME usb type-c adapter so I can at least plug it in and format it.

+ Yep I found another thread and tried out the VMD drivers, from what I could see unfortunately I couldn't see a difference 😞

That's a good idea - an external NVME enclosure will let you test the drives. I have 2 external enclosures and one of them kept freezing. Once I had updated the enclosure firmware it started working fine, so maybe that will help if you have any issues. Hopefully the drives will work OK, that just leaves working out what the problem is! I'm pretty sure that there isn't a BIOS setting to disable M.2 drives (but SATA drives can be enabled/disabled). 

Z690 Hero, BIOS 3101, MEI 2345.5.3.0, ME Firmware 16.1.30.2330, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Langleys
Level 7

Apologies , you're correct regarding m.2 drive enable/disable not being an option, its just for SATA as you said.
The external enclosure arrived this morning and I was able to connect both NVME drives and format them, then I connected them directly to the M.2 slots again while crossing my fingers.

Unfortunately, no luck as of yet

Langleys
Level 7

So I formatted both Crucial drives, and installed windows to go on one of them, then slotted it back into the M.2 slot, no change whatsoever.

I also ordered an NVME PCIE adapter, then plugged the drive into that, and plugged that into the free PCIE X16 lane, and that works. its a bit bewildering that I can't use the same drive in the other M.2 slots.