Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Z690 Hero Thunderbolt Ethernet Problems

Level 8
I'm actually not sure what the root of this issue is, but I suspect something on the motherboard so I'm posting this here: I have a problem using a QNAP QNA-T310G1T Thunderbolt to 10GbE Adapter, and I think in general my Thunderbolt is messed up somehow...

The first time I plugged in the device and installed its driver, it worked as I would expect - it was detected in Device Manager and the Ethernet connection could be used. Thunderbolt Control Centre reports it as "QNAP Systems QNA-T310G1T, Power Mode: Bus power" and all is well.

However, after sleep, with nothing unplugged or added to the system, the device is no longer recognised in Device Manager and the ethernet connection is not available. Same if I disconnect and reconnect it after a re-boot has detected it. However, the device /is/ still seen by Thunderbolt Control Centre as before. No amount of unplugging / scanning for hardwear changes etc brings it back.

If I re-boot the system with the device plugged in, it works just fine until the PC sleeps, but that seems to be the only way to make it work, and basically makes it unusable since I want the system to wake automatically to run backups on this connection at night 😕

I'm pretty sure this isn't restricted to the device, and is something weird with the Thunderbolt on this system.. I previously tried a Thunderbolt memory card reader, and ended up returning it assuming it to be faulty because it dropped the connection any time I put a different card into it or if the PC went to sleep! Now I realise it was probably exactly the same issue as I'm seeing with the QNAP..!

Anyone have any idea what is going on with this? Thunderbolt should be plug-and-play or am I missing something here?


Motherboard = Rog Maximus Hero Z690
CPU = Intel i9-12900k (modest overclock)
RAM = G.Skill Z5 Trident 64GB (2x32GB) DDR5-6000 (XMPII)
Storage = Seagate FireCuda 530 4TB NvMe
Expansion = Intel X550-T2 10GbE Ethernet Card // Creative AE-9 Sound Card

OS: Windows 10 x64 Enterprise (Note my 11th Gen Intel Laptop running Windows 11 has zero issues and detects the QNAP device straight away every time)
Drivers: All latest from ASUS website
QNAP Adapter driver: Marvell (17/12/2021) - latest listed on Marvell site for the Marvell AQtion AQC100
BIOS: Latest 2103 (problem existed on older BIOS too)