Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Z690 Formula HDD Q code 99

Level 7

so I’ve been working on water cooling my pc. It worked fine before but when trying to turn my pc for a very short test run, it got stuck on post during HDD and the Q code read “99”. I’ve searched far and wide but I never found one exact reason why this happens.

I’ve connected my peripherals, checked all cables, removed pieces, reassembled pieces, but still no luck.

any ideas on a potential fix? Thanks for reading and please do tell me anything or ask anything asap. 

i9-12900K, ROG Maximus Z690 Formula, RTX 3080 founders, DDR5 Trident Z5 at 6000 


Level 16

According to my manual, code 99 means "Super IO Initialisation". So it seems to me like something is not connected as it was before. I can only suggest checking everything again, all power leads at the mobo and PSU. Is the GPU mounted correctly still? Maybe it got knocked? Also, have you connected a sensor wire to the CPU fan connector? It might be that a CPU fan is not being detected. 

Z690 Hero, BIOS 2802, MEI 2336.5.2.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 22H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.


Hello TheRealAice,

Code 99 can be due to a couple things.

Check your mouse and keyboard are working, if they are older, you may have to enable legacy support in the bios.

Check your gpu power cables are secured and clicked into place.

Try a different monitor cable, HDMI, Displayport.

Check your monitor is getting power and working.