Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Hero Z790 - *SOME* USB devices not working / shown as "Other Devices" in Device Manager

Level 8

I have a ROG Maximus Hero Z790 and a recent Windows 11 update (apparently) messed up something in the USB system.  If I plug in any of several known good (tested on other machines) USB flash drives OR my SteelSeries Arctic pro headphones, they do not work, and show up in Device Manager as "Other Devices" with the dreaded yellow exclamation point.  Plugging/ejecting a USB stick makes the expected tone sound, but the drive does not show up in Explorer or Storage Manager.  Note that my Razer wireless USB keyboard/mouse dongle and several wired mice and keyboards DO work fine.  I tried all USB ports, rebooted, windows updated, Armoury crate updated, etc.  No luck.

ASUS Support said to update BIOS, so I used another PC to make a USB stick with the new BIOS.  Note that The BIOS DID see and access the USB drive just fine.  Just in Windows it's broken.  So I updated the BIOS to 1202, then updated all the drivers using the latest on the ASUS support website, then Armoury crate, and then the latest Intel ME firmware from  MoKiChU's thread ( [25/06/2023]).

Now USB sticks and headphones are still in "Other Devices", still don't work, and these devices are now listed under "Other Devices" as well, though they don't have the yellow exclamation mark:

Realtek Digital Output (Realtek USB Audio)
Unknown device
All of my 4 SATA and 1 NVME drives that are NOT configured for RAID (The RAID 10 / 4 NVME's all work fine, as do the non-RAID drives.)

I'm guessing this is some kind of USB host controller driver issue?  But I can't find anything to fix and I'm out f ideas.  A bunch of wired and wireless mice and keyboards work fine in any UDB port, but nothing else USB works.  I'm waiting for ASUS to reply to this new info, but if anyone here has any suggestions on where to look or what to try, I'd really appreciate it.

System Info FWIW (nothing overclocked and BIOS reset to defaults)
Windows 11 Pro Build 22621
ASUS ROG MAXIMUS Z790 HERO - Intel Z790 (Raptor Lake-S PCH)
Intel Core i9-13900K (stock speed)
64GB DDR5 SDRAM (stock speed)
ASUS TUF RTX 4090 GAMING OC (stock speed)
AIO on CPU, excellent ventilation, nothing over 45C




Accepted Solutions

OK everyone I am very sorry for not following up on this sooner, but it took quite a lot of effort with ASUS and Intel to get it solved, also life happens.  First, the i9-13900K CPU was intermittently bad, and getting worse.  As someone else found, turning off turbo made it work, but obviously that's not an acceptable solution.  I tried to get Intel to swap me a i9-13900KS for my defective i9-13900K, and they actually considered it, but in the end they just refunded me what I paid for the K CPU including tax, and I bought a KS for about $50 more (microcenter is amazing.)  Honestly I was just expecting a warranty replacement, but the refund is great.  As an aside, my old K has a silicon score or whatever of 94.  This new KS is 108, which I think is more typical.  They've definitely tightened the process and/or binned these KS chips because at lea mine is fantastic even before overclocking.

But that wasn't all.  After I put in the new KS CPU, DRAM was failing.  The B2 DIMM slot had clearly failed.  I could run with either one of my DIMMS in A2, but anything in B2 broke boot.  So I got an advance RMA from ASUS, and from the looks of it got a brand new board an not a refurb.  Now everything works perfectly.  I've shipped my old ASUS Hero mobo back to ASUS and will await the refund of the credit card hold they required.  There's no physical damage,  socket pins are fine, I put the socket cover on, so I expect no problems, but who knows with ASUS, so I gave them my corp Amex just in case they try to get stupid.

It was a lot of not fun puzzling debugging, more than on any other system I've built, and I even had to "rent" some parts from microcenter to swap things in and out to find all the problems.  But now I'm very happy, and I want to thank everyone here who offered advice or tips.  If there's interest I'll post a few pics of the system now that it's finally done and being amazing.

Thanks again,

View solution in original post


Level 17

Don't know if it will help, but try MoKiChU's "Cypress UCM (USB Connector Manager) Driver" - it's included in his Thunderbolt drivers. At least, it won't do any harm...

Z690 Hero, 12900K, BIOS 3501, MEI 2406.5.5.0, ME Firmware, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Thanks.  I ran install.cmd and it looks like it installs everything and then auto-rebooted, but I don't see any new program or app I can run to do anything.   Do you know where the installed stuff like Cypress UCM goes or how to use it?  I'm not sure how to actually use this driver beyond installing it.  It definitely didn't change anything about my borked USB or non-RAID drives.

Meanwhile ASUS bumped me up to the "next level of support" which should only take 1-2 days (wow) and gave me a huge form to fill out with every detail about my system and drivers.  So we'll see.  This is clearly a driver issue but I'm at a loss as to how to fix it.

That install you did is only drivers, so no software, I just thought it might help but I guess not 🤔 So, sorry but I'm not sure what the issue is.

You do have all drivers installed I assume - chipset, serial IO, ethernet, thunderbolt, wi-fi, Bluetooth, MEI drivers, audio, VMD drivers etc? Intel ME firmware and BIOS also up to date? (double checking serial IO drivers would be a plan). 

Next start command prompt in admin mode and try "Sfc /scannow" (without the quotes). Then, while still in command prompt, type "DISM.exe /Online /Cleanup-image /Restorehealth"

Failing the above, I can only suggest that a fresh install of Windows might be the answer, but don't forget to back up documents, browser favourites, any stored passwords, game saves etc etc. It's a pain, but I think that would be my next move. Good luck and please report back if you find out what the problem is. 

Z690 Hero, 12900K, BIOS 3501, MEI 2406.5.5.0, ME Firmware, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

I am running build 22621.2134.  There is one <Net update available, KB5029718 but otherwise, I am up to date.

I have only tried on USB drive in the front ports and it is working normally.  As far as I can tell, all of your ports are having the same problem.

I do not run a RAID configuration.  I do have an AIO which uses USB power.  My Realtek USB audio is fine and I am not using the Digital output.

If there is something you would like me to check, let me know.  Otherwise, check the Device Manager and view the hidden items to see if your USB devices are listed as greyed out.  If they are, try uninstalling them and their drivers.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

I notice my Z590 board just upgraded to 22621.2215 (KB5029351) but I do not see that update for the Z790 board, it is still on 22621.2134.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

KB5029351 seems to be pulled from windows update for some users. It can bring some bad issues on Z690/Z790 platform with lastest BIOS. There is no bug report on other platform.

Level 9

Same on my ROG Strix Z690I build (22621.2215). Uninstalling patch KB5029351 and rolling back to previous version of WIndows 11 can solve it. This bug also appeared on WIndows 11 insider preview 10.0.22631.2191 and 2199 (beta channel) one month ago, I don't understand why Microsoft didn't fix it in cumulative update of August 2023.

SFC and DISM show no error or damage. I can confirm reinstalling IO or chipset drivers cannot help at all. We have to wait for Microsoft to repair it.

Level 8

Thanks everyone for the replies and ideas.  Still nothing back from ASUS from the next level support.  SFC  /scan now, chkdsk /f, /f /r, and dism /online ‘cleanup-image /restoreheath (and /checkhealth and ‘scan health) find nothing.  The ship is sinking to a reinstall of everything, for which I am well prepared with all apps and data backed up in 1,2,3 method, so I figured I’d try uninstalling patch KB5029351.  It didn’t help, and I started getting loads of BSODs, eventually making it impossible to load windows at all.

So reinstalling windows it is!  I used windows media creation tool to make a win 11 bootable USB, dug out my license key, and then filled another USB drive with all the latest drivers both from Asus support and from every one of MoKiCHU’s threads all extracted to folders with their original zip file name.  Setup gives me 2 choices:
 1. Upgrade install windows (can’t do this because it needs a bootable, running win instance to run from.)
 2. Custom install windows only (advanced). - only option.

I start and no installable drives are listed so I need to load drivers; I’ve done this before, so OK.  I remember  post saying to install Chipset drivers -> MEI Drivers -> VMD Drivers

But CHIPSET_Intel_v1-.1.19502.8391 has no drivers in it to load.  I know I need to get RAID working so I can install windows to my (still existing) 4 x 4TB NVME RAID 10 volume.The only directories I have that include anything installable at this point are, these two, which each contain 2 drivers, one managed and one unmanaged:

1.  Intel_RST_Driver_V19.5.0.1037_WIN10_WIN11_64-bit.  
    A.  HSA and Install Dirs contain no drivers
    B.  Driver Dir includes:
         i.  Intel RST VMD Controller A77F
        ii.  Intel RST VDM Managed Controller 09AB

2.  VMD_Intel_v19.5.5.1052
     A.  Has just an install dir with the same file names as i. and ii. above.

So which to install and where are the chipset drivers I’m supposed to install first?  I seem to remember the unmanaged flavor was favored, so I install 1.b.i above.

looks good, li can now see all my drives.  My RAID10 is there, as well as all the other drives, partitions, MSRs, etc.
my 4x4TB NVME RAID10 (Drive 2 Partition 3) is my target for windows, but it says ‘We could not Create a new partition or locate an existing one.  For more information see the setup log files (wherever they are.)’  so I format that partition and try again.  Same error.  So I delete the partition and make it new.  Same error.  I delete all drive 2 partitions and make it new, SUCCESS!

That’s my story so far, windows is installing, I’ll update if anything weird happens.  Maybe this will help someone as clueless as me get through this maze.  If you have any comments or suggestions about what I’ve done or need to do I’d love to hear it.





should I try a beta bios?

What is the operation system version of your new installed Windows 11? The possible problematic one is 22621.2215 by installing KB5029351. My current stable version is 22621.2134.

I used restore point to remove patch KB5029351 instead of thru command prompt. I also tried to reinstall win11 by mediacreationtool. New installed win11 from mediacreationtool is OK because it is an early verison of Windows 11 22H2, but the issue has arise again after upgraded it to 22621.2215.

Currently, the patch KB5029351 seems to be pulled from windows update. It can be downloaded it at Microsoft Update Catalog: