Showing results for 
Search instead for 
Did you mean: 

ROG Maximus Hero Z790 - *SOME* USB devices not working / shown as "Other Devices" in Device Manager

Level 8

I have a ROG Maximus Hero Z790 and a recent Windows 11 update (apparently) messed up something in the USB system.  If I plug in any of several known good (tested on other machines) USB flash drives OR my SteelSeries Arctic pro headphones, they do not work, and show up in Device Manager as "Other Devices" with the dreaded yellow exclamation point.  Plugging/ejecting a USB stick makes the expected tone sound, but the drive does not show up in Explorer or Storage Manager.  Note that my Razer wireless USB keyboard/mouse dongle and several wired mice and keyboards DO work fine.  I tried all USB ports, rebooted, windows updated, Armoury crate updated, etc.  No luck.

ASUS Support said to update BIOS, so I used another PC to make a USB stick with the new BIOS.  Note that The BIOS DID see and access the USB drive just fine.  Just in Windows it's broken.  So I updated the BIOS to 1202, then updated all the drivers using the latest on the ASUS support website, then Armoury crate, and then the latest Intel ME firmware from  MoKiChU's thread ( [25/06/2023]).

Now USB sticks and headphones are still in "Other Devices", still don't work, and these devices are now listed under "Other Devices" as well, though they don't have the yellow exclamation mark:

Realtek Digital Output (Realtek USB Audio)
Unknown device
All of my 4 SATA and 1 NVME drives that are NOT configured for RAID (The RAID 10 / 4 NVME's all work fine, as do the non-RAID drives.)

I'm guessing this is some kind of USB host controller driver issue?  But I can't find anything to fix and I'm out f ideas.  A bunch of wired and wireless mice and keyboards work fine in any UDB port, but nothing else USB works.  I'm waiting for ASUS to reply to this new info, but if anyone here has any suggestions on where to look or what to try, I'd really appreciate it.

System Info FWIW (nothing overclocked and BIOS reset to defaults)
Windows 11 Pro Build 22621
ASUS ROG MAXIMUS Z790 HERO - Intel Z790 (Raptor Lake-S PCH)
Intel Core i9-13900K (stock speed)
64GB DDR5 SDRAM (stock speed)
ASUS TUF RTX 4090 GAMING OC (stock speed)
AIO on CPU, excellent ventilation, nothing over 45C




I was messing around this morning and realized my Z590 motherboard is not recognizing a particular brand of USB drives and those are Kingston.  The Z790 saw the drives fine.

I have not yet done the Bios update on the Z790 but will do that shortly.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200


so what’s up with your issue? I kinda experience the same messed up USB controller thing with my Z790-A prime wifi…


OK everyone I am very sorry for not following up on this sooner, but it took quite a lot of effort with ASUS and Intel to get it solved, also life happens.  First, the i9-13900K CPU was intermittently bad, and getting worse.  As someone else found, turning off turbo made it work, but obviously that's not an acceptable solution.  I tried to get Intel to swap me a i9-13900KS for my defective i9-13900K, and they actually considered it, but in the end they just refunded me what I paid for the K CPU including tax, and I bought a KS for about $50 more (microcenter is amazing.)  Honestly I was just expecting a warranty replacement, but the refund is great.  As an aside, my old K has a silicon score or whatever of 94.  This new KS is 108, which I think is more typical.  They've definitely tightened the process and/or binned these KS chips because at lea mine is fantastic even before overclocking.

But that wasn't all.  After I put in the new KS CPU, DRAM was failing.  The B2 DIMM slot had clearly failed.  I could run with either one of my DIMMS in A2, but anything in B2 broke boot.  So I got an advance RMA from ASUS, and from the looks of it got a brand new board an not a refurb.  Now everything works perfectly.  I've shipped my old ASUS Hero mobo back to ASUS and will await the refund of the credit card hold they required.  There's no physical damage,  socket pins are fine, I put the socket cover on, so I expect no problems, but who knows with ASUS, so I gave them my corp Amex just in case they try to get stupid.

It was a lot of not fun puzzling debugging, more than on any other system I've built, and I even had to "rent" some parts from microcenter to swap things in and out to find all the problems.  But now I'm very happy, and I want to thank everyone here who offered advice or tips.  If there's interest I'll post a few pics of the system now that it's finally done and being amazing.

Thanks again,

Level 7

Randy, so your saying the USB device issues were related to a bad 13900k?  because I'm having the same issue..  trying to make sure I understand you correctly.  Thanks!

If it helps anybody, I just got a CFExpress Type B card reader for my camera (it's a 3.2 Gen 2 device) and 50% of the time when I plugged it into the USB C port or my USB powered hub, the USB and/or keyboard (also plugged into a USB powered hub) would freeze and they had to be plugged back in again to get them working again. Frustrating. 

So I disabled power management on my 'USB root hubs' in Device Manager and I've had no problems since. It was a tip I found on the internet and it's now fixed. If you're having USB device connection stability issues, give it a try 😃

Z690 Hero, 12900K, BIOS 3603, MEI 2406.5.5.0, ME Firmware, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.