Showing results for 
Search instead for 
Did you mean: 

ROG HERO Z690 BIOS 2305 - Windows keeps rebooting

Level 7

I was having a strange issue where my LAN network port was showing with an exclamation mark in the device manager.  It said driver not available.  It was working for a long time, but it just decided to stop working and no matter how much i tried to install the Intel driver (through Intel and armory crate) it just never worked. I figured windows was bloated. So i bought a couple of Samsung 990 pro, and raid them (raid 0).  I loaded windows, and everything was good.  My next process was to upgrade the Intel MA and then BIOS upgrade to 2305.  Everything was successful, however now, when i boot up to windows, the computer will just reboot.  It also happens if i try loading windows from the USB installation stick.  I figured it might have been that turbo boost BS probably overclocking my pc.  I removed xmp and turned everything  to manual settings. Set RAM and CPU to a much lower speed just to make everything worked.  Still nothing.  I see the windows logo and then, reboot. It is as if i turned raid to ahci, but there is nothing in the motherboard to do that.  I tried removing secure boot, changing anything that might allow me to boot from the USB drive (even changing USB ports). I am at my witts end.  Can anyone help?


Tldr; the computer posts, starts loading windows (window logo is shown for 3 seconds) and computer reboots.  Whether it is from the internal hard drives or windows USB installation stick.


Super Moderator

Is there no stop code prior to the reboot? (BSOD). There was an issue with a recent iteration of Intel's chipset drivers with 13th gen CPUs (v10.1.19222.8341) - Boot Device Inaccessible. It's possible it was this issue, but hard to say without a stop code.
If not doing so already, I would keep things at completely optimised defaults. Don't manually select any memory parameters or anything of this nature. Returning the system to stock is troubleshooting 101. 🙂




13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 16

If that doesn't work, you should be able to downgrade to BIOS 2301. As it's another 23xx version, then that should work and hopefully get you up and running again. 2301 was a release candidate BIOS, not an official release and you'll be able to find it in the 690 forums (Asus Strix/Maximus Z690 Owners Thread) over at It also seems that there is also a way to downgrade back to 2204 from 2301 (via a special unlocked version of 2305) - have a look at this thread on these forums too -

It only works for the 690 Hero so far. Do this at your own risk of course. I haven't tried it yet, but I want to try and see if it fixes my RGB/fan issues that started happening recently.  If you try, please let us know how you got on. 

Good luck. 


Z690 Hero, BIOS 2703, MEI 2316.5.0.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 22H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Level 7

I figured it out.  I figured I would post it here to make sure this can help someone out there.  I work with a few Dell machines and I've noticed that the computer would restart as soon as the OS kernel was loading.  I used a standard Windows 10 Pro USB (that come with the retail version of Windows pro box) and that loaded.  I then used Shift-F10 to do a diskpart on the raid 0 and cleaned the disk fresh.  Everything installed Ok.  Thank you all

Glad you resolved the issue

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090