cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with switching from 13700KF to 14700K

emacec
Level 7

Hi everyone I have an Asus strix Z790i and I'm having a lot of problems switching from a 13700KF to a 14700K I updated to the latest bios version 1501 if I use the 13700 I have no problem With 14700 I don't even get to the HIVE diagnostic phase
I tested the 14700k on another motherboard (ATX not ASUS) and it starts without problems However, if I reinsert it on the Strix ITX, nothing happens The RAM is simple Kingston 5600 I did all the bios reset procedures I tried resetting the bios It almost seems like it can't recognize the CPU What could it be? Soon I will try to flashback to a previous version of the bios from the USB stick via HIVE (1402) I can't think of anything else It seems absurd to me

UPDATE 16/12/2023 21:28 - ok I tried to do the bios flashback and nothing changed

UPDATE 17/12/2023 23:03 - updated the bios to 1801 beta but no changes, I tried to start the PC without a heatsink (I got tired of throwing away thermal paste) and surprisingly the processor remains frozen, so I assume that it isn't even powered

472 Views
3 REPLIES 3

bthaanku
Level 7

did you try with only a single ram stick?  

yes and I also tested both slots individually

err88
Level 7

I have a problem with the ram. Z690-i, I changed 13700k to 14700k and I can't enable the XMP profile. PC is not posting. On 13700k it runs without a problem. Latest bios and ME from Asus website.