cancel
Showing results for 
Search instead for 
Did you mean: 

PRIME Z790-P WIFI - Bluetooth does not work

SviFi
Level 7
Did all possible driver reinstalls from Asus, from Intel, from Windows Update, from Armory Crate, does not help.
 
Windows 11 does not even show Bluetooth toggle.
In Device Manager, I see Bluetooth device appearing and disappearing by itself all the time. The event log shows errors repeatedly:
 
Device USB\VID_8087&PID_0026\5&cc3f949&0&14 had a problem starting.
 
Driver Name: oem90.inf
Class Guid: {e0cbf06c-cd8b-4647-bb8a-263b43f0f974}
Service: BTHUSB
Lower Filters: ibtusb
Upper Filters:
Problem: 0x0
Problem Status: 0xC00000E5
 
During the time when it disappears, in the General tab of the device, it shows the following error:
 
Currently, this hardware device is not connected to the computer. (Code 45)
 
To fix this problem, reconnect this hardware device to the computer.
Then after a minute, it goes to show "This device is working properly." But after another minute back to Code 45. And it repeats non-stop.
 
 
Is anyone else experiencing this? Is there a hardware issue?
The board was recently purchased and is under warranty, but I would very much hope to resolve this rather than deal with any kind of return.
Thank you!
429 Views
1 REPLY 1

JohnAb
Level 17

You could try disabling Wi-Fi & Bluetooth in BIOS, rebooting and then enabling them again. This has helped other people with similar issues. 

Z690 Hero, 12900K, BIOS 3501, MEI 2406.5.5.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.