cancel
Showing results for 
Search instead for 
Did you mean: 

No POST no BIOS no Beeps in ROG STRIX Z790-F GAMING

sambatyon
Level 7

I am starting a new build with:

  • Board: ROG STRIX Z790-F GAMING
  • Processor: Intel Core i9 14900K
  • RAM: Corsair Vengeance 2x32 GB (also tried with Kinston Fury 2x32GB)
  • SDD: 2 Samsung 4TB
  • PSU: BeQuiet Dark Power 10 (I savalvaged it from my previous computer)

At the moment that is pretty much that is connected as I removed anything which wasn't super essential.

What works: 

  1. BIOS upgrades have succeeded, or at least the light start bliking before turning fully off after ~5min
  2. The RGB colors of the board work and are in sync with the cooler lights, it did also sync with the ones of the graphics card, before I removed it.
  3. All the fans seem to be working without problems.
  4. Power and reset buttons work.
  5. I have also reset the CMOS a couple of times both, through the button and by removing the battery for a couple of minutes (though I have no way of verifying if this works)

What doesn't work:

  1. On start I see the CPU led turns on before turning itself off and then the DRAM led turns on and stays there.
  2. I got a buzzer speaker but no sounds are produced (though I cannot confirm the buzzer is working)
  3. No screen output from either the HDMI nor DisplayPort outputs. When the GPU was connected, there was no video coming either.
  4.  The keyboard lights don't turn on, nor the mouse ones, no matter which USB I connect them to.

I am out of ideas at the moment so any help would be welcome.

394 Views
7 REPLIES 7

Nate152
Moderator

Hello sambatyon

So, when you try to start your pc it hangs on the Dram led (yellow light).

Try this.

1) Shut down your pc and turn off the psu switch.

2) Install one stick of memory in the A2 slot (2nd slot from the cpu).

3) Press and hold the clear cmos button for 3 seconds.

4) Try booting up your pc.

 

 

 

sambatyon
Level 7

Hi Nate152, I just attempted that with each of the 4 memory sticks, one at at time. Same symptoms every time.

Nate152
Moderator

Thank you

If it's not working with any of the memory sticks in the A2 slot, then it's possible your cpu cooler is a little too tight or you may have some bent cpu socket pins.

Try loosening the cpu cooler mounting screws a little then try booting. If this doesn't help, remove the cpu cooler and inspect the cpu socket for any bent or misaligned cpu socket pins. Check carefully with a magnifying glass in good lighting.

You can post us a picture of the cpu socket if you like.

 

 

 

 

 

 

I tried let loose the cooler and even tried just holding it with my hand, didn't work. I tried to get pictures as good as possible, I saw three teeth which I would call weird which you may notice in the first picture, you can still zoom significantly without lost of quality

DSC04948.JPGDSC04946.JPGDSC04945.JPGDSC04944.JPG

Nate152
Moderator

Thank you,

Your pictures are a little blurry, but it does look like there are a few socket pins out of place.

cpu socket.png

Can they be fixed, or is the only option to get a new board?

Nate152
Moderator

They can be pushed back into place, be careful when straightening them as the pins can snap off.

I would try straightening them before purchasing a new motherboard. In this video, the person used a pair of small tweezers, you can use a sewing pin or needle or a round wooden toothpick might work to straighten them.

A good eye and steady hand are key.