cancel
Showing results for 
Search instead for 
Did you mean: 

Nahimic services

Roachman43
Level 9
I have a Asus ROG z790f and i use the onboard audio but every bootup i get an issue with this nahimic services, it's either svc32 or svc64 won't start and i get the following errors in Reliability Monitor,

Description
Faulting Application Path: C:\Windows\System32\NahimicSvc64.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: NahimicSvc64.exe
Application Version: 2.7.7.0
Application Timestamp: 62f5f11c
Fault Module Name: SonicStudio3_DaemonModule.dll
Fault Module Version: 3.16.23.0
Fault Module Timestamp: 6209d66d
Exception Code: c0000005
Exception Offset: 00000000000150a4
OS Version: 10.0.19045.2.0.0.768.101
Locale ID: 2057
Additional Information 1: f7e4
Additional Information 2: f7e4b76d33386c4292636e0f19f9c28e
Additional Information 3: 8b27
Additional Information 4: 8b27f9567fa4e8c77f4dfd89aa777d3f


Description
Faulting Application Path: C:\Windows\SysWOW64\NahimicSvc32.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: NahimicSvc32.exe
Application Version: 2.7.7.0
Application Timestamp: 62f5f0e5
Fault Module Name: DeviceRoutingDaemonModule.dll
Fault Module Version: 2.2.11.0
Fault Module Timestamp: 620334d9
Exception Code: c0000005
Exception Offset: 00008a3b
OS Version: 10.0.19045.2.0.0.768.101
Locale ID: 2057
Additional Information 1: 2beb
Additional Information 2: 2beba6fb4680d73a8c78ca7c24ccdb46
Additional Information 3: c406
Additional Information 4: c406b406f851ca2a5d210d9d7cd7e09e


I don't get just 1 or 2, I can end up with 50, I have to restart my pc many times to get the services to start and stay running, with them not running sonic studio won't open and my audio is poor.

I have the latest drivers (from the thread in this section) installed following the instructions from the realtek post and i have reinstalled them about 4 times but still the same thing happens.

Can someone help me, all i keep reading is, uninstall this ****, but i like the enhanced audio i get from it so i'd like to keep it unless there is another audio manager program i can use
Asus Rog Strix Z790-F | Intel i7 13700 KF | Asus Nvidia GeForce RTX 4080 TUF | Corsair Vengeance DDR5 2x16GB | Asus Rog Strix LC II 240 | Samsung 980 Pro, 1TB | MSI MPG A850G PCIe5 ATX 3.0 | Win 10 | Asus Rog Strix Scope TKL | Asus Rog Gladius II Origin
3,313 Views
12 REPLIES 12

MoKiChU
Level 40
Hi,

You have an ASUS ROG SS3|DTS Sound Unbound motherboard with ALC408x codec, so :

You need Realtek USB Audio Drivers (UAD - ASUS ROG SS3-DTS) from the first post of this thread : [DRIVERS] Realtek USB Audio (Intel 5xx/6xx/7xx & AMD 5xx/6xx/TRX40).

- Follow scrupulously your CLEANUP process
- Use this SS3 Cleaner tool (Right click on "A-Volute_SS3_Cleanup.exe" > Run as administrator) then restart your PC
- Follow scrupulously your INSTALL process


For the next drivers packages that I would release, you will can directly follow your UPDATE process.

I know, I already have it installed, i've reinstalled like 5 times.
97827

I forgot to check what nahimic is installed with, if it's only for sonic studio i might uninstall that and use a EQ program/app instead
Asus Rog Strix Z790-F | Intel i7 13700 KF | Asus Nvidia GeForce RTX 4080 TUF | Corsair Vengeance DDR5 2x16GB | Asus Rog Strix LC II 240 | Samsung 980 Pro, 1TB | MSI MPG A850G PCIe5 ATX 3.0 | Win 10 | Asus Rog Strix Scope TKL | Asus Rog Gladius II Origin

Roachman43 wrote:
I know, I already have it installed, i've reinstalled like 5 times.
97827

I forgot to check what nahimic is installed with, if it's only for sonic studio i might uninstall that and use a EQ program/app instead


Your motherboard type that you have and the drivers package that you need was more for information purposes in case you used an incorrect drivers package for your motherboard.

I know that you have reinstalled several times, you said it in your previous post, but you did not indicate how and if you used SS3 Cleaner tool or not.
So follow the procedure I gave you in my previous post, and if your issue persists and you want to get rid Nahimic/Sonic Studio then install Realtek only, follow this post : https://rog.asus.com/forum/showthread.php?127457-Remove-Sonic#post853847

Sorry about that, I can't recall using ss cleaner, i did it this way,
97829

doing it this way i probably didn't use ss cleaner, pffff, i'l give it another shot
Asus Rog Strix Z790-F | Intel i7 13700 KF | Asus Nvidia GeForce RTX 4080 TUF | Corsair Vengeance DDR5 2x16GB | Asus Rog Strix LC II 240 | Samsung 980 Pro, 1TB | MSI MPG A850G PCIe5 ATX 3.0 | Win 10 | Asus Rog Strix Scope TKL | Asus Rog Gladius II Origin

MoKiChU wrote:
Your motherboard type that you have and the drivers package that you need was more for information purposes in case you used an incorrect drivers package for your motherboard.

I know that you have reinstalled several times, you said it in your previous post, but you did not indicate how and if you used SS3 Cleaner tool or not.
So follow the procedure I gave you in my previous post, and if your issue persists and you want to get rid Nahimic/Sonic Studio then install Realtek only, follow this post : https://rog.asus.com/forum/showthread.php?127457-Remove-Sonic#post853847



I have done as you ask and still same problem,

Description
Faulting Application Path: C:\Windows\SysWOW64\NahimicSvc32.exe

Problem signature
Problem Event Name: APPCRASH
Application Name: NahimicSvc32.exe
Application Version: 2.7.7.0
Application Timestamp: 62f5f0e5
Fault Module Name: DeviceRoutingDaemonModule.dll
Fault Module Version: 2.2.11.0
Fault Module Timestamp: 620334d9
Exception Code: c0000005
Exception Offset: 00008a3b
OS Version: 10.0.19045.2.0.0.768.101
Locale ID: 2057
Additional Information 1: 2beb
Additional Information 2: 2beba6fb4680d73a8c78ca7c24ccdb46
Additional Information 3: c406
Additional Information 4: c406b406f851ca2a5d210d9d7cd7e09e

Is there a way i can start these manually or get them to stop from trying to start if they crash, i mean my audio is fine when they crash, it just sonic studio won't open but my EQ settings seem to save
Asus Rog Strix Z790-F | Intel i7 13700 KF | Asus Nvidia GeForce RTX 4080 TUF | Corsair Vengeance DDR5 2x16GB | Asus Rog Strix LC II 240 | Samsung 980 Pro, 1TB | MSI MPG A850G PCIe5 ATX 3.0 | Win 10 | Asus Rog Strix Scope TKL | Asus Rog Gladius II Origin

MoKiChU
Level 40
Roachman43 wrote:
Is there a way i can start these manually or get them to stop from trying to start if they crash, i mean my audio is fine when they crash, it just sonic studio won't open but my EQ settings seem to save


Hi,

You can start/stop/restart Nahimic Service by this way : Press Windows key + X > Task Manager > Services tab > Right click on NahimicService service > Start/Stop/Restart.

But it's more optimal to fix the issue at the root cause rather than to start/restart the service manually, or stop it to avoid event errors in Reliability Monitor. So : Press Windows key + X > Task Manager > Services tab > Right click on NahimicService service : Open Services > Right click on Nahimic service service > Properties > Check that Statup type is on Automatic and not on Automatic (Delayed start) (if this is not the case, configure it in Automatic > Apply > OK > Restart your PC).

The service is configured by default on Automatic and not on Automatic (Delayed start), if the service was configured on Automatic (Delayed start) you have to see from your side what/who switched that (I suspect Armoury Crate and its profils). Also, note that when services are configured in this way (Automatic (Delayed start)) the service is started 120 seconds after Windows starting.

Evening.

It's on default, automatic.

Do the Problem signatures give you any info as to why they are crashing ?
Last few days I've been looking a dac amps, i'll have to go that route if this can't be fixed, so annoying, nearly £500 mobo
Asus Rog Strix Z790-F | Intel i7 13700 KF | Asus Nvidia GeForce RTX 4080 TUF | Corsair Vengeance DDR5 2x16GB | Asus Rog Strix LC II 240 | Samsung 980 Pro, 1TB | MSI MPG A850G PCIe5 ATX 3.0 | Win 10 | Asus Rog Strix Scope TKL | Asus Rog Gladius II Origin

MoKiChU
Level 40
Roachman43 wrote:
Evening.

It's on default, automatic.

Do the Problem signatures give you any info as to why they are crashing ?
Last few days I've been looking a dac amps, i'll have to go that route if this can't be fixed, so annoying, nearly £500 mobo


Indeed, your issues are maybe related to a ZoneID blocking trouble. To avoid ZoneID blocking trouble, either :

- For each downloaded .zip : ZoneID unblock the .zip (Right click on the .zip file > Properties > Check the box Unblock > OK).

or

- Disable the ZoneID blocking completely (you will no longer have to unblock each downloaded .zip) :

- Right-click Windows Start button then click Launch then type gpedit.msc > OK
- User Configuration > Administrative Templates > Windows Components > Attachment Manager
- Do not preserve zone information in file attachment : Enabled > OK > Restart your PC


That said, re-download your drivers package then ZoneID unblock the .zip (Only if you have not disabled the ZoneID blocking completely) : Right click on the .zip file > Properties > Check the box Unblock > OK then follow scrupulously your CLEANUP process then your INSTALL process (with the unlocked drivers package), for the next drivers packages that I would release, you will can directly follow your UPDATE process (with the unlocked drivers package).

MoKiChU wrote:
Indeed, your issues are maybe related to a ZoneID blocking trouble. To avoid ZoneID blocking trouble, either :

- For each downloaded .zip : ZoneID unblock the .zip (Right click on the .zip file > Properties > Check the box Unblock > OK).

or

- Disable the ZoneID blocking completely (you will no longer have to unblock each downloaded .zip) :

- Right-click Windows Start button then click Launch then type gpedit.msc > OK
- User Configuration > Administrative Templates > Windows Components > Attachment Manager
- Do not preserve zone information in file attachment : Enabled > OK > Restart your PC


That said, re-download your drivers package then ZoneID unblock the .zip (Only if you have not disabled the ZoneID blocking completely) : Right click on the .zip file > Properties > Check the box Unblock > OK then follow scrupulously your CLEANUP process then your INSTALL process (with the unlocked drivers package), for the next drivers packages that I would release, you will can directly follow your UPDATE process (with the unlocked drivers package).




Hi MoKiChU, I have the same issue since the last update (SS3 APO SoftwareComponent Driver : 3.5.6.0 WHQL [21/11/2022]), i followed those instructions bit still I have the same issue... Is there another way to fix it?