cancel
Showing results for 
Search instead for 
Did you mean: 

Motherboard Maximus Z790 FORMULA, does not detect ram

alimoukdad
Level 7

Hello i, this is my specs:

Core i9 14900k  ,,,Rog Maximus Z790 Formula Motherboard ( new model 2023) ,,,,Corsair Dominator Titanium  2  x 32GB (CMP64GX5M2X6600C32W) ,,, SSDSamsung 990 pro 2tb,, Asus Strix 4080 OC white ,

Problem: 

i was usiing my rams on my previus motherboard a Rog strix z790-A gaming , everything was perfect, the motherboard did recognize the 64gb on 6600 mhz,

now i bought the 14th G 14900k and this new motherboard, and turn out the motherboard its only detecting 32Gb no matter witch slot am using, for example, i can use 32gb in all the slot , and it will recognice it, but as soon as i connect the 2 second ram, it wont recognize it, only 32gb, so, i dont know whats going on here, the motherboard its new, barely 5 h of use.! ive tried to use different dimms configurations, and still its not detecting the  64Gb, ONLY 32GB.  the argb light for both rams are on, but the OS and the BIOS, does not detect this ram, any suggestion please, i need your help guys! 

 

500 Views
3 REPLIES 3

Silent_Scone
Super Moderator

Hi there,

Clear CMOS, if issue persists:

Remove CPU and cooler. Check socket for any pin damage and reattach cooler whilst checking for consistent mounting pressure. Dropping DIMM slots is often due to improper pin pad contact.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I'm having trouble with z790 formula and Corsair Titanium 2x24gb 7200 kit RAM too. It will boot with XMP profile but will hang or crash immediately with gaming or work.

Someone at the Headquarter, please see to update the new bios to fix this, I have tried both 0220 and 0506 bios versions. Nothing is fixed, seems to be worse than fixing anything. It's a 750 usd motherboard so I expect more out of it. 

alimoukdad
Level 7

I did all that bro, nothing, am using a Ryujin 3 water coolant kit, i checked everything, clean thermal paste, all the contacts and pins are ok ,, i dont know what to do