cancel
Showing results for 
Search instead for 
Did you mean: 

Memory / System Unstable immediately after reboot

cthree
Level 9

Hello,

Before I begin, here are my specs:

  • Windows 11 (23h2) Latest Update
  • Intel 14900kf / Deepcool 360 AIO LS720
  • Asus Rog Maximus z790 Hero / BIOS 1801 (latest) / Intel ME 16.1.30.2307
  • MSI RTX 4090 Suprim Liquid X 24G
  • G.Skill DDR5 7200 (2x16) - F5-7200J3445G16GX2-TZ5RS
  • Samsung 980 Pro SSD NVME 1TB Gen4 & Sabrent 1TB Rocket NVME (SB-Rocket-1TB)
  • MSI MPG A1000G PSU - 1000W
  • Steelseries Apex Pro TKL Keyboard.  Also swapped to Corsair K70 TKL to test.
  • Lamzu Thorn / Atlantis Mice.  I've tried wired mice as well to see if wireless was causing an issue.
  • Sound - I swap between a wired headset (Beyerdynamic DT 990 Pro) which is plugged in to an amp and then internal soundcard, and a wireless USB headset.
  • BIOS Settings - Everything currently default except for memory set to XMP1, rebar / 4g disabled, fan speeds adjusted to turbo (CPU & Pump set to Full speed).  MCE disabled (PL1 / PL2 = 253w), E-Cores disabled, secureboot / TPM ON, CSM disabled.

All drivers installed and currently on the latest BIOS 1801 (ME 16.1.30.2307) , chipset / intel me/ serial IO / etc.

Now on to the problem...

I'm experiencing what appears to be a memory stability or training issue where my system becomes unstable after the first reboot.  The only time my system runs well and games don't lag or stutter is after a cmos flash or bios flash.  After a bios or cmos flash, I'll set XMP 1, boot into Windows and all is well.  However, when I reboot or shut down my system and power back up, all my games become overrun w/ input lag and stutter.  It's a night and day difference.  My first thought was memory instability but it just doesn't make sense that the only way to fix it is by flashing either the bios/cmos to correct the issue.  If it works the first time, it should certaintly work the second time unless something is changing behind the scenes.  I've attempted lowering my memory frequency all the way down to 6400 from 7200 1 step at a time to see if any of these frequencies will resolve the issue. The confusing part is that I'll still continue to pass memory stress tests such as y-cruncher VST, tm5, linpack, memtest86, etc, even though all of my games now are clearly lagged and inputs delayed.  This very fact makes this a very difficult issue to troubleshoot.  W/ that said, I've also tried disabling mrc fast boot and fast boot.  The only thing that makes sense to me is that the memory is training poorly upon reboot regardless of the mrc fast boot setting.  I also tried locking in my memory values right after a bios/cmos flash and enable mrc fast boot, but that doesn't seem to work either.  Memory temps are NOT an issue and never break 40 degrees during gaming.  I even have a mini fan pointed at them because I dabble in memory overclocking.  I'd also like to note I've tested my system at the stock/default memory profile where my memory runs at 4800mhz, same story.  Runs just fine after the initial flash, and then performance tanks after the first reboot or power off.

I have been dealing with lag/stutter on this setup for quite a while now, and I'm pretty sure it's related to memory training but I can't be 100% certain.  Anyone have any thoughts or suggestions on how to resolve this?  I know asus has dozens of memory training algorithms and I wonder if any of these settings can ensure my memory trains properly every single time.  Any help will be appreciated.

986 Views
1 ACCEPTED SOLUTION

Accepted Solutions

MRC Fastboot is enabled by default. The "best way" to train the memory is to use parameters that are stable. Most of the MRC settings do not need to be touched. The easiest method for tuning memory is  tuning voltages for VCCSA, IVR TX, etc. If the system is stable at stock (no XMP or overclocking) then there's nothing wrong with the CPU or drivers.

 

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

View solution in original post

18 REPLIES 18

Nate152
Moderator

Hello cthree

What I might do is install HWinfo, with HWinfo running play a game. 

When the lag sets in, check all your components are working normally.

Check your gpu clock speeds to make sure your gpu is ramping up, you can also check to see it's drawing the recommended wattage. 

Post a screenshot of Hwinfo after your games lag, be sure to include the maximum columns. Maybe this will tell us something.

It can also detect errors as shown on the far right.

Click the pic to make it bigger.

HWinfo.png

 

Thank you for the response!  I have already gone to great lengths troubleshooting this.  I've confirmed that my ram, gpu, psu, nvme drive are good, either through extensive stress/stability testing and/or switching them out with a known good piece of hardware.  I've already swapped out my cpu/psu/ram/nvme with known good ones just to ensure it wasn't hardware failure of some type.

W/ that said, I'll gladly post all columns of hwinfo64 tomorrow when my system will likely begin to lag after rebooting.  My short term fix in the interim is to flash cmos, jump into the bios and enable XMP1.  When doing this, my system will be perfectly stable and responsive until I reboot.  Maybe you'll catch something I overlooked.

After starting up my system again today, everything is back to lagging.  Here are my system stats during a game.

 

cthree_0-1707002643957.png

 

 

 

FixItWorse
Level 9

Also, what are you running for storage? What GPU do you have in there? Which drivers?

The input lag, which peripherals are you using, how do they connect? Wired? Wireless?

Across all games equally?

Do some handle it better than others?

What are your UEFI settings, specifically things like ASPM and Virtualization.

Need a lot more info, but we can likely help you get to the bottom of it.

 

Hisense U7G 55" 4K, HDR, 120hz w/FreeSync VRR Primary Display
Corsair 5000X Black iCue, ROG STRIX Z690-E GAMING WIFI w/ Intel 12700K, AIO Cooled by Corsair H150i Elite Capellix, Gigabyte Aorus Master RTX 3080 Ti, 32GB (2x16) Corsair Dominator Platinum @ XMP Tweaked, 4x 1TB WD850 Black NVMe, 2x on HyperCard in Raid 0, and 2x in M2.2 and M2.3 on Mobo.
SeaSonic TX1000W Platinum PSU... I'll finish this soon.

Hey man, thank you for taking the time to help me out!

GPU is MSI RTX 4090 Suprim Liquid.  Currently the latest drivers.  I've tried previous drivers as well resulting in no impact on my issue.

NVME drive is a Samsung 980 Pro 1tb (4th gen) and a Sabrent 3rd generation 1tb nvme

Keyboard: Steelseries Apex Pro TKL.  I also have a Corsair K70 RGB TKL which I tested with to see if my keyboard was rhe culprit.  

Mouse: Currently using the Lamzu Thorn / Atlantis OG 4k. Both wireless. I've also tested using wired to rule out the mouse along with every polling rate, no impact.  I have also tried every USB port.

Sound: I swap between a wireless and wired headset.  No difference when using either my wired (connected to sound card via 1/8th stereo connector), or Wireless (usb).

Networking: I currently use the onboard intel NIC with latest drivers.  I've also installed a realtek 2.5gb pcie nic to test, no change.

When I experience the clear input lag/stutter, it's across all games.  The problem remains until I clear cmos and enable xmp1.

UEFI settings: XMP1, I leave ASPM at defaults currently.  What I have learned with the rtx 4090 is that it doesn't seem to like aspm disabled.  It's okay to disable native aspm and clock gating, but fully disabling aspm in the bios results in stutter/hitches.  This was not the case with my 3080.  With that said, I've also tested disabling aspm, yet my problem rears it's ugly head after rebooting or shutting down and powering back up.  I've tested virtualization on/off.  Fast boot on/off, secure boot and tpm on, csm disabled, rebar and 4g disabled.

As I mentioned earlier, I have a strong suspicion that memory training is good after a clearing cmos and then memory trains poorly after rebooting or shutting down.  I've spent a lot of time tuning my memory with the hope of resolving this and despite how stable I get my memory, even with loose timings, my system will become unstable out of no where because I rebooted.  I'm curious what else other than poor memory training could cause such behavior.

There's a free little program called Latency Monitor that might reveal something useful. 

JohnAb_0-1706869151852.pngJohnAb_1-1706869197570.png

Also, when you are running HWInfo, check out the WHEA errors section. 

If you see issues in either, at least it's a start in terms of where the problem might be. 

Z690 Hero, BIOS 3401, MEI 2406.5.5.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Hi John,

Appreciate the tip.

I'm already aware of latency monitor and have been using it for years and dpc latency checker pre windows 10.  My DPC latency is excellent w/ no spikes.  I use this quite a bit to confirm I'm not running faulty driver causing dpc latency issues.

Also, no WHEA errors. 

Silent_Scone
Super Moderator

As above, best to list all system specs. Storage especially, as there have been some GEN 5 drive teething issues.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hi There,

I've come across many of your replies in the past.  You're obviously quite knowledgeable in general but also w/ memory overclocking and configuration.  Do you have any suggestions on the best way to train memory on this board and how to immediately lock in those settings?  On other boards I simply disable fast boot and/or enable fast boot (slow training) on say an MSI board, and then once I'm happy w/ my memory settings, I immediately go back into the BIOS and enable fast boot to stop my memory from being trained further.

Also, could a faulty intel me or chipset driver be contributing to this?  The behavior that I experience screams memory instability issues since performance varies greatly from each reboot.  Since my sticks pass every mem test after hours and hours of stress tests, I can't help but think it's a training issue.  I've tested and checked virtually everything else.