Showing results for 
Search instead for 
Did you mean: 

Maximus Z790 Hero - Logitech G915 wireless keyboard, cant get into BIOS....any ideas?

Level 7

I have to use a wired keyboard to get into the BIOS screen. Anyone knows why it doesnt see my wireless G915 (fairly expensive) keyboard? I cant believe its not working. Should be a setting in the BIOS...which unfo i do not know it...:-)

On another note, I also have plugged on the USBs of the mobo some fans for my sim racing rig and when i shut down my windows those fans continue to work like i have have not turned the PC off. Presume this is also a setting in the Bios sending power in the USBs continuously. Do you know which setting is that to turn it off?

Kindly appreciate yr assistance 🙂



Level 11

have you tried putting the USB wifi dongle on other USB ports in the back of the computer that are active on boot of the system for the Keyboad/mouse issue?

Intel Core i9 103900KS
Asus Maximus Z790 Extreme [bios 1303]
LG (34U97-s) Monitor 3440 x1440
Nvidia RTX 3090 FE
Windows 11 Pro
64gbz Memory

Of course man! I have tried ALL USB ports. 3.2, 3.1 all of them. The G915 and the mouse NEVER work! Never! It should have to do with a setting in the BIOS which probably I still do not know and thats why I am in here...looking for someone who knows...:-)

I CANT believe that we live in 2023 and the most expensive wireless keyboard of Logitech, the G915 cannot get you into the BIOS of the Maximus Hero mobo. I use an old wired keyboard from HP to log into the BIOS. This is simply a joke....😂 

Level 7

It seems that NOBODY has a bloody solution for this? pfff....I cant believe i paid a fortune for one of the high end mobos and it doesnt get me into Bios with the more expensive Logitech keyboard.....its tragic....😂

Level 9

I have the z790 Hero and I have 2 wireless keyboards, a Microsoft Split/Ergo Keyboard and an Asus Rog keyboard.  Both can get into the bios by hitting Delete at boot time.  I can't answer why your logitech can't.  If you can get into Windows, you can open a command prompt and enter the following command to reboot into bios.  Hope that helps.

shutdown /r /fw /t 00

Super Moderator


Try toggling Legacy USB Support in the UEFI as well as XHCI Hand Off.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090