cancel
Showing results for 
Search instead for 
Did you mean: 

MAXIMUS Z790 DARK HERO + CRUCIAL T700 PCIE 5 M.2

ComteZer0
Level 8

Hello There,

I have a Maximus Z790 Dark Hero with a 14900K, 4090 and a crucial T700 PCIe5 M.2.

T700 is in M2_1 (G5 Slot)  Slot on the motherboard.
My intel ME firmware version is : 16.1.30.2264
T700 is in last firmware : PACR5102
Motherboard Bios version is : 0507

In advanced menu, my M.2_1 Link speed is set to Gen5.

My problem is that the T700 is running at PCIe 4  speed instead of PCIe 5 speed

I have read Bios and motherboard manual
and some thread in this forum and crucial forum, nothing work.
I need help.

1,556 Views
19 REPLIES 19

Silent_Scone
Super Moderator

Hi,
Can I ask what makes you think the drive is running at the wrong link speed?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Hello Silent_Scone,
In CrystalDiskInfo it's noted PCIe 4.0 x4 | PCIe 5.0 x4 (Running | Max)
ComteZer0_0-1700753109336.png
And in CrystalDiskMark He as same perf as my GEN4 SSD

ComteZer0_1-1700753495601.png

 

 

tomcoleman
Level 9

comtezero i have the same issue on my Asus X760E with a T700 4TB.

thread and testing here > T700 NVME PCI 5 hanging - Republic of Gamers Forum - 972660 (asus.com)

Also MSI owners have the same issue MSI MEG X670E GODLIKE - M.2 SSD Crucial T700 not working in PCIe 5.0 Mode | Page 3 | MSI Global Engl...

Now a Z790 user (you) has the same issue.

When your in GEN5 mode on the M.2_1 port do you see a bunch of errors (153) in the event viewer? specially if your writing to the disk with crystaldiskmark

 

Silent_Scone
Super Moderator

1TB T700 here on Apex Encore in M.2_1

No changes to NVME behaviour made in BIOS, just memory settings. 
BIOS 070

NOTE: Not directly pertaining to being stuck in GEN4 mode, but please make sure to select NVME Mode under settings in Crystal Bench

Silent_Scone_0-1700762711568.png

Silent_Scone_0-1700763437110.png

 

 

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

ComteZer0
Level 8

It's seem that the problem is not bound to motherboard or Size of T700, maybe a bad Micron chip ?
i have checked i have set crytal to nvme parameters.

ComteZer0_0-1700773481592.pngComteZer0_1-1700773502256.pngComteZer0_2-1700773561382.pngComteZer0_3-1700773723366.png

ComteZer0_4-1700773903457.pngComteZer0_5-1700773972855.png

ComteZer0_6-1700774048798.png

I have no error in event log related to NVME, every works fine but the nvme is not at full speed
The T700 is my OS drive
 My Kingfury G4 have same states for half the price.

ive spent days on this problem and not really got anywhere.

Have you hardset your PCI to Gen4 for the GPU and GEN5 for the NVME? in slot m2_1?

Have you also tested the NVME in slot m2_2 with that hard set?

I can get my t700 in GEN5 mode but windows is super unstable and get a ton of errors in the event viewer then bluescreen curruptions but in GEN4 mode its perfectly fine.

 

Your screenshot there is showing the drive as in GEN5 mode/slot but running at GEN4 mode, i noticed your GPU is also x8 mode and not x16.

as per here

Intel Core i9 processor 14900K 36M Cache up to 6.00 GHz Product Specifications

your chip only supports max 20 PCI lanes

have you got any other PCI/NVME/SATA connected as might be reducing speed sharing lanes etc.

generally GPU is 16 lanes, NVME is 4 lanes, chipset is 4 lanes and so on. This is why i didnt go intel this time as the 7950x offered 24 lanes where intel is only 20 lanes.

shooting in the dark here but worth a look.

ComteZer0
Level 8

All my pcie slot are hard set
M2_1 is hard set Gen5
M2_2 is hardset in Gen4
PCIEX16(G5)_1 is hardset in Gen5
Only M2_1 is Gen5 capable
On manual i have this

ComteZer0_0-1700830406721.png

ComteZer0_1-1700830454916.pngComteZer0_2-1700830511566.png
i have seen that M2_1 gen5 and M2_2 Gen5 are on cpu PCIe lanes. i will move drive from M2_2 for testing.

from yoru screen shots it says M2_2 is PCI GEN4 only?

No point setting PCI_1 to Gen 5 (there are no GEN 5 GPU's currently?)

M2_1 is the best slot for your NVME according to your screen shot.

 

Necrophobias
Level 7

I'm glad I found this thread -- I'm just going to post a summary of the issue I've been having with the Crucial T700 1TB and what I've discovered through my own troubleshooting:

I have an ROG Z690-E running the latest BIOS as of writing (2802), i7 14700-K, RTX 4080, 32GB Crucial DDR5 5600.

I noticed issues with this drive straight away when I installed it in my system in the (M2_1 slot which supports Gen5). I tried to format it in windows and immediately when trying to create a new simple volume in Disk Management, the drive disappeared and could no longer be accessed.

I intended on using this as my new boot drive, so I tried cloning my current boot drive to the T700, which cloned successfully, but immediately upon trying to boot into windows I got a BSOD with the error stating that a registry file was missing. I restarted and tried booting into windows again on the T700 and got a BSOD and it said Windows needed to be repaired. Running repair failed, and the system was never able to boot into Windows.

Assuming this might have been an issue with the clone, I then tried to do a clean install of Windows on the T700. I had no errors during the initial install of windows, but once the system needed to be restarted to continue installing Windows, I immediately got a BSOD with the same issues as above when I tried to clone my original boot disk. Immediately I knew something was up, so I tried installing Windows on a different Gen 3 NVME drive (in the M2_1 slot to be sure it wasn't just the slot malfunctioning) and it worked flawlessly.

Assuming the T700 was defective, I actually ended up returning the original T700 I bought and just exchanged it for a new T700 hoping that maybe it was just a one-off issue.

Installed the NEW T700 in my system (M2_1 Gen5 slot), tried to do a fresh install of Windows again, and ran into the exact same issues as above where I couldn't even boot into windows to finish the installation and would just get a BSOD.

While researching this issue, I saw some people were able to use the drive while forcing the M2_1 slot to run at Gen4 instead of Gen5 in the BIOS. So, I forced the slot to run at Gen4, clean installed Windows on the T700, and it worked flawlessly. Then I made sure all my drivers were up to date in windows and I installed the Crucial NVME Driver for Windows.

I was curious if I could now just switch the M2_1 slot back to Gen5 in the BIOS, so I did that and it was able to boot into Windows, but I immediately noticed the system was running slower than it was when I had the slot on Gen4. I tried to start Discord and noticed that the application was crashing immediately even though it wasn't doing that when it was on Gen4. So I uninstalled and tried reinstalling Discord and got an error saying the application couldn't be installed.

To (hopefully) avoid corruption I immediately restarted and switched the M2_1 slot back to Gen4. Booted back into windows and so far everything has been running fine. I did get a windows notification to "restart to fix drive errors", which I did, and I haven't gotten that notification since.

So there appears to be some incompatibility with the T700, seemingly across multiple motherboard manufacturers (as stated above, some MSI users are experiencing similar issues). I'm not sure if maybe it's trying to use too many PCIe lanes or there's some other incompatibility. Unfortunately this is as far as I could get and I was unable to find a solution at this time other than just forcing the slot to be Gen4.