Showing results for 
Search instead for 
Did you mean: 

Maximus Extreme Z690 - Thunderbolt Code 12

Level 9

I am losing my god d*mn mind here. I had a 12900K with my Z690 Maximus Extreme and everything worked perfectly.

A couple months ago I upgraded to a 13900KS and ever since my Thunderbolt hub has not worked right. With the latest BIOS update the new problem is 'Thunderbolt controller -1137' in device manager is saying Code 12 not enough resources. 

I'm on the latest drivers of everything and yes I've tried uninstalling and reinstalling all drivers. IT'S A BIOS ISSUE. I'm never buying one of these crap motherboards again.

The error occurs only if I startup from a shutdown. It disappears if I restart. So it's not a problem with the device itself, it's something else.


UPDATE: SOLUTION FOUND (Technically a workaround but effectively a solution) - I'll just copy what I posted in the other thread:

Link to post in other thread:

Reposted Below:

FINALLY I was able to figure out a solution, for my case at least. Which was to enable the "ErP Ready" setting under Advanced > APM Configuration. For me the options were "Disabled", "S4+S5", and "S5". I changed it to S5, but I imagine it might work with the S4+S5 option too. I believe S4 allows for hibernating, and I'll explain S5 next.

From my understanding, what enabling this setting and using S5 shutdown does, is make it so when you shut down your computer, it completely shuts down, putting it into a state called S5. Where only a trickle of power goes to the power button and stuff to turn on.  Whereas I guess without it, some stuff still runs in a low power state - I know before, when I "shutdown" the motherboard's OLED and light effects were still going.

In my case, the thunderbolt dock would work fine after a restart, but if I turned on the computer from a "shutdown" state (not S5), it would have the problems. Now, it works both when I restart, and when I turn it on from a full S5 shutdown. So no, this is not a absolute 100% solution if you don't want to keep your computer in S5 vs the other state, but I think it's the best we got so far.

Therefore, my theory is that whatever the problem is, it has to do with the thunderbolt interface coming out of a low power state, and (at least in my case) specifically when a dock was connected and turned on while this occurred. Because for me, if I had the dock powered off while the computer booted from not-S5 shutdown, but turned it on afterwards, it would work. 

>> Extra Note: It seems the "Code 31" and "Code 12" errors I was having on some devices in device manager were actually cause by memory issues, and seemed to be separate from the issue I solved above. Basically I have 128GB of RAM and apparently even though I've been using XMP II at 4400 MHz for over a year, with the latest BIOS that was causing instability. So I disabled XMP and then manually set the RAM frequency to 4400 MHz, leaving all the other RAM settings as Auto. After this, the yellow exclamation mark and errors in device manager disappeared. Though the weird problem with the thunderbolt dock not working still persisted, until I found the solution above.