cancel
Showing results for 
Search instead for 
Did you mean: 

LAN not working for Win 11 install on Z790-E motherboard

Sag
Level 8

Hi all.

Spent two days now trying to figure out why something so simple isn't working.  I've read problems with drivers and intermittent issues but I can't get Win 11 to see the LAN connection at all during install, so I'm stuck.   I can't / don't want to use WiFi.  Yes, tried multiple cables, ports, and even routers.  Green light blinks on LAN port on mobo but Win 11 doesn't see anything.

Advanced -> On Board Configuration does have Intel LAN enabled.

At this point, I have to assume it's a bad board and if I have to rip everything out, will go with MSI upon return.

Can anyone let me know what I could be missing for something so simple that shouldn't be such a headache?

3,973 Views
19 REPLIES 19

PaulyFromMichia
Level 9

I had this same problem on my z790 hero. this is what i did. 

Downloaded the latest NIC and WIFI drivers from the link in this post https://rog-forum.asus.com/t5/downloads-for-motherboards/drivers-intel-ethernet-wifi-bluetooth/td-p/...  ( I got this link from JohnAB thanks John!)

Then install windows, when it comes to the page asking for the internet and your stuck

hit SHIFT and F10, it will pull up a command window. Type oobe\bypassnro (mind the \ here is the one above the enter key) and hit enter

it will reboot, just got through it again and when it comes back to that window, at the bottom it will say "i dont have internet" click that and then the next page click "i dont have a product code" it will allow you to continue with the install.

When you get into windows install the drivers by the instructions in the post, basically extract the drivers to your drive somewhere, go to device manager, go to Ethernet and Wi-Fi, update driver, and point it to the directory you extracted the drivers to.

 

this is just a backdoor way to install windows with a local account, but I used it to get passed this issue. I think it might be something with the updated windows installer since your having it on a differnt model MB. maybe they didnt add this version of intel nic drivers or something. I dunno, hope this helps!

Thank you!

I think this would also solve it but I finally used a neighbor's WiFi to connect and finish the install and then updated the LAN drivers as Windows 11 didn't even recognize it, and now it works as expected.  Where this machine is, it can't get WiFi (long story) and doesn't need it except for this.

I still can't exactly figure out what the unrecognized UCM-UCSI ACPI unrecognized device is or the RAID controller, but I don't need either and some more Googling should solve it.

Thanks

I have the same issue with the usb thing. right now and am currently looking for the solution. I think its something with the USB driver and USB c  or something

but the raid controller is the chipset I think, I got it from here

https://rog-forum.asus.com/t5/downloads-for-motherboards/drivers-intel-chipset-mei-vmd-6xx-7xx/td-p/...

Thanks,

The first thing I did was follow Mokichu's guide and install the Intel Chipset from [DRIVERS] Intel Chipset/MEI/VMD (6xx/7xx)

That said, I didn't install VMD driver update as I couldn't quite figure out what device was VMD and if I needed that step, unless RAID is VMD?

I think it is. I extracted the 3  from his post and then from the control panel I updated the driver and pointed it to the folder the 3 where extracted to. 

Got it

UCM-UCSI ACPI unrecognized device on a Asus Z790 is the thunderbolt driver. 

https://rog-forum.asus.com/t5/downloads-for-motherboards/drivers-intel-thunderbolt/td-p/914542

Thanks!  That is it, and my last one - RAID - was indeed VMD.   Mochiku's stuff, when read and understood, it helps so much.  Really appreciate your help as well.

Once things click, it all seems so simple in hindsight.

Yes sir! enjoy your new build!

Thanks, I have a similar problem with the Z790-E, but the thing is, there are no "unrecognized devices" in the device manager, I've tried to disable and re-enable the LAN card in the BIOS but with no luck 😞 have any idea what can I do?