Showing results for 
Search instead for 
Did you mean: 

i226 V2.5 Problems?

Level 8

Level 12
Mine seems fine. I am using it with a 2.5 Gbps connection. Just make sure and install the correct, updated drivers.

When I first installed Windows 11, the install could not find drivers for the Ethernet but there are drivers on the flash drive which comes with the motherboard.

And you can bypass the network connection being required.
Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

Level 12
testing with some ideas. i will report back in 24h. I have it also on z690 12th .
Learn, Play Enjoy!

Level 8
Ohh yea I can tell you that definitly there is a issues, I have every few hours this error on widnows event viewer and sometimes I can notice the itnernet cut. Tried already with different drivers but still happaning. Z790-F MB

Level 9
This is interesting, I never noticed anything because it happens so fast, but I do have these events in my event log.

And I use this PC daily for work, teleconferences and everything.

Level 9
So I did some more research and it turns out this is not actually a problem for me.

Yes I do have the e2fnexpress event id 27 and 32 events in my system event log but they don't ever happen as long as I am using the computer.

The only time they happen is when I am away from my computer and the machine is returning from sleep.

My event viewer is showing these "disconnect" events as well but as far as I have been able to backtrack (the last four to five days) the disconnect event only happens when I boot up my computer for the first time or when I restart the computer.

Of course, my memory only reaches back so far but I can say with confidence that there was no disconnect event that was NOT related to booting the system during the last five-ish days.

In the longer term, I will have to keep an eye on the event viewer and keep track of my boot times to be really sure but so far it is looking like my mainboard may not be affected by *random* disconnects.
I only get a "disconnect" event when the system first boots up which I would guess simply happens when Windows is loading the drivers.

I got the ROG STRIX Z790-E GAMING WIFI and LAN drivers

Super Moderator
The event codes in the article will appear when the system comes out of power states, so it's a little misleading. I am not experiencing any problems on the Z790 Apex and driver, Windows 11 2H22. Either at 1GB Full Duplex or 2.5GB full Duplex.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

I seem to have solved the problem, i have no event id 27 or 32 aside from when the system boots or shuts down. (Which is normal behaviour)

This is my setup as it comes to the i226-V adapter on Windows 11:

Driver: (Windows 10 uses the 1.x driver)


After that i disable the 'Energy Efficient Ethernet' option in the driver. This feature shuts down parts of the SoC for energy efficiency when not used, this happens in s0 and s0ix state. The s0 state means fully operational, since i disabled this and set the speed to 1Gb instead of auto negotiation the event id's haven't appeared again.


I'm curious if this fixes the problem for other people too. I haven't checked if it still happens with auto negotiation enabled yet, but my network is 1Gb anyway.

Level 8
Anyone else having problems currently have the Z790-i motherboard

What would i do if i build this and have problems could i just use wifi or a USB C ethernet adapter