Showing results for 
Search instead for 
Did you mean: 

Hero Z690 Got 4 sticks of DDR5 RAM to work in XMP at last!

Level 9

Originally on my Maximus Hero 690 with a 12900k and 4 sticks of  DDR5 Corsair Vengeance 4800 mhz when it first released until TODAY I have never been able to get XMP to work without boot errors / BSOD etc.... I did manage to get it working at 4200 I think it was once but a new BIOS ended that.

Yesterday I installed the 14900k into my 690 on the latest BIOS 2802 and today I decided to enable the XMP as an experiment at 4800 and it worked, I ran a 3DMARK test and it seems stable, cant believe it....  

Just thought I would post in case others are in the same boat...


Windows 11 | Rog Maximus Z690 Hero | i9-14900K | Corsair Vengeance DDR5 4800mhz 64GB | MSI 4090 SUPRIM X | Apollo x16 | Quantum 2626 | ASUS ROG Swift OLED PG48UQ | H150i RGB Pro XT | AX1200i | Dark Core Pro SE | K100 RGB


Super Moderator

That's good to hear. Gen on gen, generally the IMC will become more capable.  Intel officially supports 4400 MT/s if 4 modules are populated, so you're still achieving an overclock in this configuration.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090