cancel
Showing results for 
Search instead for 
Did you mean: 

GPU Not Detected Windows 11 Pro (Maximus Hero Z790)

Nemorosum
Level 7

Well, I'm back and not by choice. To start off with, I've never nothing but problems with every ASUS product I've ever owned and I let someone talk me into it. I 110% regret it, this whole PC build has been a cluster**** of a nightmare. So, let's see if someone on this forums can restore an ounce of my faith in ASUS. Below is my current build.

CPU: Intel i9-13900K 3Ghz 24-Core
CPU ILM: Thermal Grizzly Intel Contact Frame 12th Gen
CPU Cooler: Arctic Liquid Freezer II 420
MOBO: ASUS ROG Maximus Z790 Hero
RAM: G.Skill Trident Z5 RGB 64GB DDR5 6400 CL32
NVMe0: Samsung 970 EVO Plus 2TB PCIe 3.0 X4
GPU: MSI RTX 3060 Ti VENTUS 3X OC
CASE: Fractal Design Torrent ATX Mid Tower
PSU: SeaSonic PRIME PX-1300 Fully Modular
OS: Windows 11 Pro
FANS0: Fractal Design Prisma AL 140mm x3
FANS1: Fractal Design Prisma AL 180mm x2
BIOS: v1501

Note: The GPU will eventually be a 4090, however my 2070 decided to kick the bucket and I needed to be able to use my PC. I purchased something equivalent to a 2070 but newer to be able to perform the same amount of work I did before. I plan to purchase a ASUS TUF Gaming RTX 4090 24GB Card after the 15th when my stocks can be cashed out.

 So here's my issue.

Windows 11 Pro 64bit, does not see my GPU, whatsoever. I can connect an HDMI cable to it, and get display over it, but Windows doesn't see it. It won't even let me install drivers for it, because it can't detect anything is there. The fans spin, and work, I get display over it. Am I missing something in the settings or something? I didn't have this issue with my 2070, all I had to do for that was update the BIOS. I'm getting to the point where it's going to go outside, and find out what a slug is. I'm a pretty tech savvy person, I work in IT but more specifically, I scale Networks for a living. It requires a fair amount of skill to decipher what the hell Network Engineers are up too. So, I'm not a complete idiot but I haven't built a new PC since i7-7700K was new. So I am lagging behind.

919 Views
6 REPLIES 6

Hopper64
Level 14

I’m wondering if windows is detecting the HDMI as part of the iGPU on your 13900k? Don’t know. Check setting to disable that in bios or try a display port cable rather than the HDMI? Not sure here. I use a DP cable and have not had this problem before. ??

MZ790A Bios 2002, GSkill F5-8000J3848H16GX2-TZRK, 13900KS, EKWB D5 TBE 300, Seasonic Prime TX-1600 ATX 3.0, Asus Strix 4090 w/ Optimus block, Phanteks Enthoo Elite, Asus Claymore 2, Asus Gladius 3, Asus XG349C, Samsung 990, Windows 11 Pro

I've posted on 6+ different places, and someone from LTT suggested I re-do my mounting brackets for my CPU. I'm going to give that a whirl, and see. The Thermal Grizzly mounting bracket is extremely fickle and can cause problems if not done right.

Hurtzrus
Level 7

I had the same problem using the thermalltake 1650w power supply on my ROG 4090. I was using the cable supplied by thermaltake and connecting to the 12vHPWR slot on the PSU. It didn’t provide enough power being connected to this slot and just got a red light and not detected in windows and it drove me up the wall. Bought a 12vHPWR cable with 3 CPU/PCI connectors on it and one 12vHPWR straight into the graphics card and it worked perfectly and detected it straight away. I thought maybe the cable so tested 3 other 12vHPWR cables and got the same. If you new 1300w PSU has two 12vHPWR slots on it try a cable with two connectors one end and one for the graphics card. Not sure if this cures your problem but if your as frustrated as me it’s worth a try as it worked perfectly and hasn’t missed a beat since.

I used this one off Amazon if it helps 

https://amzn.eu/d/2Qv9wYz

 

So, my 3060 Ti has 2x 8pin power slots, and doesn't use the 4090 connector. But you're absolutely right for the 4090, I do have a 12vHPWR cable for when I eventually move to the 4090.

I wish manufacturers would give better instructions on what power cables are acceptable to use. The MSI website has this ungodly cartoon to explain things, which makes me never want to buy MSI again =/

As I stated above in response to the first comment, I'm going to re-do the contact plates and what not. Start over from scratch if I can.

rulik006
Level 8

Try second pci-e slot
i've seen similiar problem on z690 hero, when no signal until reset 

FixItWorse
Level 8

IMO, I think you would be having bigger problems if the CPU wasn't making proper contact. Like another poster said, try disabling the iGPU in UEFI and see what that gets you.

Was this a fresh install of Windows? Also, update to latest UEFI if you haven't, and check for possible VBIOS upgrades for the card from MSI.

And make sure to try an alternative slot as another said.

Also, which slot do you have that Nvme in? If it's nearest the CPU, you might want to rethink that as well.

 

Hisense U7G 55" 4K, HDR, 120hz w/FreeSync VRR Primary Display
Corsair 5000X Black iCue, ROG STRIX Z690-E GAMING WIFI w/ Intel 12700K, AIO Cooled by Corsair H150i Elite Capellix, Gigabyte Aorus Master RTX 3080 Ti, 32GB (2x16) Corsair Dominator Platinum @ XMP Tweaked, 4x 1TB WD850 Black NVMe, 2x on HyperCard in Raid 0, and 2x in M2.2 and M2.3 on Mobo.
SeaSonic TX1000W Platinum PSU... I'll finish this soon.