Showing results for 
Search instead for 
Did you mean: 

Do Not Update Intel ME Firmware to Version

Level 9

I have ROG Maximus Apex z690 motherboard and I attempted to update the Intel ME firmware to the latest version that is on the ASUS website and it completely bricked my motherboard.

During the installation process it went to 9% and it shut down my whole computer. I attempted to start it and it wasn't responding at all. I unplugged everything plugged everything back on and nothing. Power is going through because the start LED button and the button underneath it that says flex key or eliminated. However the motherboard is not going to turn on at all.

I tried everything to revive. It even did a bios flashback and that didn't help either.

The good thing is this motherboard has dual BIOS and I was able to boot from there and update the bios to the version. I want it and everything worked fine so at least now I have a working PC again.

I feel like this is completely unacceptable. If Asus didn't do their due diligence and they did not test this firmware on their motherboards because clearly it bricks the whole system.

I am running a bios 2204 by the way.

Be careful guys and do that at your own risk. Because clearly something is wrong here and I have been using ASUS products for years and I have been updating bios and firmware so many . I've never experienced anything like this. It really scared the hell out of me.


Level 9


I just Update to me and it seems to worked fine on my 690 apex and also update the bios, so far so good and i had xmp on while doing the me and bios Updates 

Level 8

Hey there. I have some issues with 2176 ME FW updatetool on my ASUS TUF Gaming Z790-plus wifi, but not even close that catastrophic. 

First i updated from stock ME FW into ME FW 2124 without problem. 

Than i tried to update into ME FW 2176 and it completed installation, but it was surprisingly fast, only 1-2 seconds. Message poped up saying installation is complete, click to reboot your system. I rebooted and everything was fine. Later i checked ME FW version in BIOS and still shows ME FW 2124. So installation didnt go through after all. Thats all, no other problems. 

I reported it to asus costumer service and have some feedback, but no solution yet. My guess is file is corrupted somehow.

ASUS TUF GAMING Z790-PLUS WIFI / BIOS v1220 / ME FW v16.1.27.2176 / ME interface driver v2316.5.0.0

Good to know, thanks for sharing. Some people aren't reporting any issues, some are reporting minor issues, I got the most severe looks like...

Hey, update to my sideproblem. After clean Windows install, ME Firmware v2176 installed successfully, as well Bios  v1205.

Problem was outdated Management Engine Interface driver. Turns out one unmentioned third party driver updater messed up my drivers, so latest ME interface driver wont update. After reinstalling all drivers manually from Asus website everything works fine.

ASUS TUF GAMING Z790-PLUS WIFI / BIOS v1220 / ME FW v16.1.27.2176 / ME interface driver v2316.5.0.0

Level 8

I'm pretty sure on my Z590-i with the latest ME updates I saw it shut off and on randomly like this. It's best to not try to interfere and hit the power button or anything that could interrupt it. Just kick the process off and walk away, go make a sandwich. You definitely don't want to get impatient and start pulling power plugs or hitting buttons. That's what it sounds like happened. Just RMA it to Asus, they'll send a working board back to you.