Showing results for 
Search instead for 
Did you mean: 

Do Not Update Intel ME Firmware to Version

Level 9

I have ROG Maximus Apex z690 motherboard and I attempted to update the Intel ME firmware to the latest version that is on the ASUS website and it completely bricked my motherboard.

During the installation process it went to 9% and it shut down my whole computer. I attempted to start it and it wasn't responding at all. I unplugged everything plugged everything back on and nothing. Power is going through because the start LED button and the button underneath it that says flex key or eliminated. However the motherboard is not going to turn on at all.

I tried everything to revive. It even did a bios flashback and that didn't help either.

The good thing is this motherboard has dual BIOS and I was able to boot from there and update the bios to the version. I want it and everything worked fine so at least now I have a working PC again.

I feel like this is completely unacceptable. If Asus didn't do their due diligence and they did not test this firmware on their motherboards because clearly it bricks the whole system.

I am running a bios 2204 by the way.

Be careful guys and do that at your own risk. Because clearly something is wrong here and I have been using ASUS products for years and I have been updating bios and firmware so many . I've never experienced anything like this. It really scared the hell out of me.


Super Moderator


I’ve not seen any other reports of this online. Did you clear the CMOS before attempting to run the update via EZFlash?

any reason why you’re not using USBFlashback?


13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

This is for the Intel ME Firmware, not the BIOS. I did attempt to use bios flashback to fix it, bit it didn't work.

Did the system simply shut down or did it hang at 9% and then subsequently shutdown? Sounds more like an unfortunate crash. Can you confirm if the system was at Optimised Defaults? XMP disabled?

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

It wasn't at optimized defaults or xmp disabled. It wasn't hanging at all. The moment I started the installation it went to 3, 5, 9 % and it just immediately shut down. My system is stable, no crashes or anything. I was very confused when it happened. 

Yeah, seems others are having different issues with it. I would say what I experienced is pretty severe. It literally bricked my motherboard. I could not turn it on at all. I was lucky the mobo has a second bios and I switched to it and was able to start it again. If I try to use the first one, the mobo does not power on at all. 

Level 12

i have seen other reports on other forums that this was version has been causing issues. not nearly as severe as how you have it but i know its causing some headache.

Level 11

FWIW, I made sure I had the latest Intel Chipset (Intel MEI_v2306.4.3.0_2023-06-29) installed on Windows 11 and re-booted before installing  Intel ME v16.1.27.2176.  The ME installed without any problems. I followed that with flashing to BIOS 2602. 

My ROG Strix Z690-F Gaming WiFi has been running just fine since doing all of the above a few days ago.

Have a Good One! 😎

Yes I attempted to do the same thing and I also had the latest driver as well but mine went terribly wrong. I do not know why.