Showing results for 
Search instead for 
Did you mean: 

Clean Install W10 - Audio Driver Without All the Nahimic Sonic Stuff

Level 9

I posted this in an older thread but received no responses. And when I ask this question over at 11 Forum, the Author of the drivers deletes my question because apparently, Im not smart enough to figure it out on my own. So I am looking for someone who might be willing to offer an idiot a nudge in the right direction as I am trying to solve this "Nahimic" issue. Thank you in advance.

From this older thread:

"I want to accomplish the same thing (Except im on Win 10, but I downloaded the file "AUDIO_Realtek_USB_UAD_ASUS_ROG_SS3-DTS_v6.3.9600.2355" from MoKiChU, located here:

And there was no "Install.cmd" file located anywhere within that file structure that I could see to do a fresh install of Windows 10? Where is it or do I have the wrong file? Thank you,"



Windows 10 Pro - 64 Bit / ASUS ROG Strix B650E-F Gaming / AMD 7800X3D / G.Skill Trident Z5 NEO 64GB DDR5 6000 Ram / SSD M.2 SK hynix Platinum P41 2TB / MSI Gaming GeForce RTX 4090 SUPRIM Liquid X 24G / SteelSeries Arctis 7 Headset /LG-Ultragear 38" IPS LED Ultrawide HD Monitor (3840 x 1600) / Track IR4 / Thrustmaster TPR Pendular Rudder Pedals / Virpil HOTAS VPC Constellation ALPHA-R & VPC MongoosT-50CM3 Throttle



Level 16

I'll try to help, but I can't guarantee it will work. As a first step, backup your OS and then if the following creates a mess for any reason, you can always do a restore. I like Macrium Reflect, but don't forget to create a bootable USB so you can do the restore if needed (or, you can always re-install Windows if you prefer). Anyway, after that...

Grab MoKiChU's latest audio Realtek audio driver pack from here:

Unpack it and you'll see install.cmd. 

I think you have 3 options as follows...

1) Run install.cmd as admin (which will also install the stuff you don't want) then remove it afterwards *

2) Go directly to the Drivers/Realtek folder and install using setup.exe (I think this will just install the Realtek drivers) - probably the best/easiest option if it works. 

3) Edit the install.cmd file and rem out what you don't want (like in the other instructions you linked to)

* If you do option 1, it's a pain to remove the extra stuff but it can be done as follows (these instructions are based on MoKiChU's own instructions):


If you already have the following installed:

Realtek USB Audio Drivers
Realtek Audio Control/Console
Sonic Studio III
Sonic Radar III
DTS Sound Unbound

Uninstall what you don't want (probably everything except Realtek USB Audio Drivers) by going to Start > Settings > Apps. Right click and select uninstall, then restart the PC

Launch Driver Store Explorer (search for it on the web) as admin. Check the boxes of any drivers (*.inf) beginning with:

realtek (think you should keep this one)
rtdusbad (think you should also keep this one)

Check the box "force deletion" then click on the "delete driver(s)" button

Next, Open Device Manager. Under "View" check "Show hidden devices". Look in "Sofware components" for the following:

DTS Audio Effects Component
DTS APO4x Service Component

If present, uninstall them with right-click/uninstall device and restart the PC

Now run the SS3 Cleaner software - right click on "A-Volute_SS3_Cleanup.exe". Run as administrator and then restart the PC. You can find this software in MoKiChU's threads. 

Extra Note: I do have SS3, DTX Sound Unbound and Realtek Audio Console installed. They cause me no problems, so I would say it's OK to ignore them and just don't use them if that's your preference. You could also ask MoKiChU directly in his audio driver threads. He's very helpful and gets the credit for what I've posted here and should be able to help you. I'm not really an expert, but nevertheless I think the above should work for you. Good luck. 


Z690 Hero, BIOS 2802, MEI 2336.5.2.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

AHA! I found the problem!!! First off, thanks being a gentleman and offering your help sir! Initially, I tried to follow the instructions and run the "Install.cmd", problem was (as stated above), I couldnt find the "Install.cmd" file? And when I asked about it over on the other forum, my post got taken down and I was ridiculed for basically being an idiot. Thats when I came in here to ask the same question. your response prompted me to download the file a 2nd time and compare,, and WALA! The initial file I downloaded did NOT have that file in it, along with apparently a missing "APPS" folder? I posted a screen shot comparing the same exact files, but the one on the left is the initial one I downloaded that is missing some files, and the one on the right is the one i just downloaded. This idiot thanks you sir for making me consider that I might actually have a corrupted file to begin with. And your instructions by the way are very clear and helpful! I will be addressing this sometime this week with attempting to just install the Realtek drivers on a fresh install. Thank you again sir!




I am interested in your original question regarding Nahimic and not wanting it installed.  I have to assume you know what it does, so what is it that makes you want to remove it?   Is too much processing power being used or some other system performance degradation?  It appears to be related to gaming immersive audio.  The original thread stated they did not want any of the SS3 software, not just the Nahimic.

I will assume, if you install SS3, it will also install the Nahimic utilities.  Maybe there is a way around it but that might lead to other system problems.

I also had a little problem finding the Install.cmd file, but I don't usually use special drivers.  It was informative to see what audio components are actually installed on a normal system. 

There are many different types of Audio problems being seen in the forums.

Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

I dont truly know what its function is to be honest. Im just trying to solve problems. The 1st being that it was causing problems with "VoiceAttack" software in my Flight Sim (DCS) and I was getting alot of distorted and crackling sounds while in the Flight sim. Extensive searching all brought me to a common culprit, and that was Nahimic (And VoiceAttack software stated in a message that Nahimic was installed and it could cause conflicts). SS3 was also noted within my searches as a potential issue as well. So my goal is to try and just install the Realtek drivers and see how she floats with just that.

Ok thanks, I will look around a little.  I don't use that particular game, but I might experiment with it.  

One thing I have noticed about games is, they don't seem to identify the type of sound being used, which makes it harder to pin down an exact cause.

Take care.

Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

Level 16

Pleased to be of service. I find that the Realtek drivers and associated other apps (if you want them) are the most problematic to get installed and then get everything working. In fact, last time I tried I actually went back to one of MoKiChu's older driver packs and installed that because it had update.cmd which worked for me. Only today I noticed that my Realtek driver was xxx.2347, not xxx.2355 as installed. It was reported as xxx.2355 in Armoury Crate, but xxx.2347 in Device Manager.  Go Figure. I reinstalled the 2355 pack and it didn't change, so I manually updated the Realtek driver in Device Manager by unpacking the latest driver pack and pointing Device Manager to that folder for the driver. Now Device Manager also reports that I have xxx.2355.

No fault of MoKiChU's driver packs, I just find that these Realtek drivers are a pain and they never seem to install consistently. Sometimes I let Armoury Crate install these drivers and maybe I get SS3 to appear, sometimes not. Sometimes SS3 works as intended, sometimes not. But, I usually get there in the end! Have fun and like I said, ask MoKiChU if you need proper expert help. 


Z690 Hero, BIOS 2802, MEI 2336.5.2.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

Level 9

Sorry to hear you had to deal with that! Out of all of my builds, this is the 1st time i had to deal with sound drivers being so problematic. I chose not to install ArmoryCrate during install, i read to mmany negative things about it. But I did install ASUS Sound drivers. The short version of this is that Nahimic was causing problems with VoiceAttack, and i was getting alot of distortion and crackling while flying my Flight Simulator (DCS). I did eventually follow the instructions to clean it all up, but felt there were alot of garbage crumbs left behind and I still had occasional distortion. I decided that I want to do a fresh install and rid myself of the garbage and bloatware. Thats why I was looking to find a vanilla driver. I will do a fresh install this week and hope for the best. By the way, I do frequent backups with Acronis, so i can always restore back. This time, i will install windows and chipset drivers, then do a backup BEFORE I install the sound drivers so I can quickly restore back if need be. Thanks for the help!

Level 16

I do have SS3 installed, but perhaps also worth noting that it does cause the file synchronisation software I use to backup my files (FreeFileSynch) to crash occasionally. If I uninstall SS3 then the problem goes away. 

Z690 Hero, BIOS 2802, MEI 2336.5.2.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.