Showing results for 
Search instead for 
Did you mean: 

Can't register motherboard and can't contact support without doing so!

Level 8
I am trying to register my Z690-A Gaming WiFi D4 motherboard that I bought about a year ago, but the Asus site won't let me. I input the S/N (double and triple checked on the box) and the date of purchase, but the SUBMIT button just remains 'greyed' out.
So, I tried to contact Asus support, but apparently I need to register the product to do so!!!
If anyone can help me here, I would appreciate it.

Level 8
So, after looking for others who had experienced the same thing, I noticed that they had resolved it by using the Asus app. They were right, that worked!

Hey thanks, I was having the same issue. Ill give it a try!


Level 16
I had the same problem and I solved it by numerous e-mails, photos of the box, proof of purchase. Took about 3 weeks and it was obvious that each agent hadn't read the previous e-mail history, so I was going in circles for quite a while. I'll try and remember to use the App in future then, thanks.
Z690 Hero, BIOS 2802, MEI 2336.5.2.0, ME Firmware, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.