cancel
Showing results for 
Search instead for 
Did you mean: 

Can only enter BIOS if monitor is using onboard GPU

RMPLP
Level 8
New build as follows:

ASUS ROG STRIX Z690-E GAMING WIFI
Intel Core i5-13600K
G.Skill Trident Z5 RGB 32 GB (2 x 16 GB) DDR5-6000 CL36 Memory
ASUS TUF Gaming GeForce RTX 3070 Ti OC V2 Edition 8GB GDDR6X TUF-RTX3070TI-O8G-V2-GAMING
KINGSTON KC3000 1TB PCIe Gen4 NVMe M.2, Read: 7000MB/s; Write: 6000MB/s Solid State Drive
Samsung 870 EVO 4TB SATA III, Read:560 MB/s, Write:530 MB/s Solid State Drive
CORSAIR RMx Series RM1000x 80 PLUS Gold Fully Modular ATX Power Supply
ACER CB282K 4K Monitor

Problem: When monitor is plugged into the motherboard HDMI port, the ASUS Logo/splash screen is displayed on startup and I am able to enter BIOS. When monitor is plugged into the RTX 3070 Ti HDMI port no ASUS Logo/splash screen is displayed on startup, and no amount of hammering on the Del or F2 keys will load the BIOS screen.

BIOS has been updated to 2204 to support 13th Gen CPU, and I have tried setting the BIOS primary graphics setting to PEG, PCIE and CPU without it making any difference. Apart from that, the machine works as expected. Is there any fix for this or am I doomed to having to re-plug in my HDMI cable into the motherboard whenever I want to enter BIOS? Any advice appreciated!
3,708 Views
5 REPLIES 5

xarot
Level 11
Try disabling fast boot, lengthening the boot splash logo display time, and playing around with CSM settings.
Main: i9-10980XE - Rampage VI Extreme Encore - 64 GB G.Skill Trident Z Royal 3600 CL16 - Strix RTX 3090 - Phanteks Enthoo Primo - Corsair AX1500i - Samsung 960 PRO 1 TB + Intel 600P 1TB - Water cooling
HTPC: i7-6950X - X99-M WS - 32 GB G.Skill RipjawsV DDR4-2400 - GTX1050TI - Bitfenix Pandora - Corsair AX860 - Intel 750 400 GB + Samsung 1 TB 850 EVO
All around: i9-7980XE - Rampage VI Extreme - 64 GB G.Skill 4000 CL18-19-19-39 - Strix RTX3090 - Phanteks P500A - Samsung 960 EVO 512 GB - Water cooling

@xarot -

Enabling CSM did the trick. It was disabled by default.

Thanks so much for your assistance.

It would be nice if ASUS published detailed instructions for their BIOS settings. Cheers.

ricardo3200
Level 7

I'm with the same problem on a new build.

ASUS ROG STRIX B760-F gaming WiFi

Intel i7 13700f

16gb+16gb memory

Gigabyte Nvidia 1070 GTX (8GB)

No access at all to BIOS probably because the CSM funtion is not enable on BIOS but without access to it is impossible to do the changes.

Worst of it is even to enable the secure boot i need to access BIOS and nothing...

I dont know what to do more to try to access BIOS menu...

JohnAb
Level 17

Can you get hold of another GPU to try? Then you might be able  to access the BIOS, change the settings and then go back to your main GPU.

Z690 Hero, BIOS 3401, MEI 2345.5.3.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.

JohnAb
Level 17

One more idea - I remember that when I used to set CSM on my previous PC, the video output for my two monitors would swap around. So, you might get an output if you try the other ports on you GPU or connect a second monitor. 

Z690 Hero, BIOS 3401, MEI 2345.5.3.0, ME Firmware 16.1.30.2361, 7000X Case, RM1000x PSU, i9 12900K, ASUS TUF OC 3090TI, 2 x 16GB Corsair RAM @ 5200MHz, Windows 11 Pro 23H2, Corsair H150i Elite AIO, 4x Corsair RGB fans, 3x M.2 NVME drives, 2x SATA SSDs, 2x SATA HDs.