Intel 700 & 600 Series
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Exploring the impact of DDR5 in 2024 [Intel 14th Gen]

I thought I'd share some results on Intel 14th gen and the ROG Z790 Apex Encore with memory scaling whilst investigating use cases for DIMM Flex. As most will know, in the exploration of DDR5 it's crucial to recognise that substantial CPU and memory ...

240316084855.jpg Silent_Scone_0-1711563201839.jpeg 4800MT.png JEDEC [Auto].png

Make Future Motherboard Feature Suggestions Here!

Hi all,ASUS ROG is requesting our best suggestions for ROG product improvements. As a moderator I won’t have the ability to implement your suggestions but I will be picking some of the best to highlight for the ROG team so they know what matters to u...

xeromist by Moderator
  • 20063 Views
  • 152 replies
  • 106 kudos

ROG STRIX Z790-F GAMING WIFI DONT DETECT GPU

Hi,So i just recently rebuild my pc with this new motherboard and new CPU and all that.When starting it up it seems like the GPU in the PCIEX16(G5) FIRST SLOT. Does not get detected.I tried plugging it in the other slot PCIEX16(G4) works fine! BUT i ...

Resolved! Z790-Pro WiFi RVM Temperature swinging from 0-125 Deg C

I've just built a new system using the TUF-Gaming-Z790-Pro-Web motherboard, Intel i9 14900K, Asus, Corsair 850W Power Supply, 64Gb DDR5I've installed Windows 11 and Drivers updates then Hardware Monitor and I noticed the VRM Temperature swinging from...

chart.jpg temp.jpg
cgaa642 by Level 7
  • 627 Views
  • 2 replies
  • 1 kudos

Z790-F m.2 heatsink screws

Does anyone know what size the screws used to hold the m.2 heatsink on are?I somewhat damaged the head of one of the screws while screwing in and was wondering if I could get a replacement screw or two from ebay or somewhere.Thanks!

Retired by Not applicable
  • 446 Views
  • 1 replies
  • 0 kudos

Z790 Hero not running GPU as PCIE 4.0 X16 but 3.0 instead

So got a new build with Z790 Hero paired with a 13700k and GTX 3080 12GB and I noticed with GPUz it says gpu supports up to PCIE x16 4.0 but its running at x16 3.0.I went into the bios and selected Gen 4 on PCIE but no change gpu is in the top socket...

Raigoz by Level 7
  • 4901 Views
  • 25 replies
  • 2 kudos

Voltage Overkill?

I just purchased a 14900kf and I'm thinking that these vcore and VIDs voltages are insane for idling. I'm sure I'm missing some extreme AUTO setting that Asus has set to Auto and is causing this thing to take a lot of extra voltage. I have everything...

Screenshot 2023-11-06 222405.png