Showing results for 
Search instead for 
Did you mean: 

B760-F no post, shuts down

Level 8


I just bought the rog B760-F, can't seem to be able to post, this is what happens:

Power on on the PSU, fans start, post LED lights go red, yellow the back to red, yellow and the PC shuts down. Power is still on.

Tried all memory config in 1 bar / 2 bars setup. Nothing works.

Flashed the bios correctly by usb. Cleared the cmos by button on the MB.

Any ideas what might be wrong?




Hello Reddy75

When you boot up, it should go Red, Yellow, White and Green. When it turns green your monitor should come on.

It seems your not getting the White light which could be pointing to your gpu. 

Do you have a gpu installed? Double check the pcie power cables are fully connected and a monitor cable is connected to your gpu and monitor.

Make sure your monitor has power.





Level 8

HI, thanks for the reply - unfortunately it never gets to green/white, it's red - yellow - red - yellow and it shuts down... takes about 2 seconds.

I have a 3070 which is connected to a monitor and properly connected to the PSU. It powers up ok in the beginning (leds+ fans) but shuts down (predictably) as soon as the POST fails.

I have 2x16 gb corsair vengeance DDR5 CMK32GX5M2B6000C36 which are not on the memory compatibility list for the MB, but this shouldn't cause this kind of issues, isn't it?

I'm starting to suspect a faulty MB



Looking up your memory kit, it says it's designed for the latest Intel ddr5 motherboards so I would think it should work.

You could try powering down your pc, turn off the psu switch and install one stick of memory in the A2 slot (second slot from the cpu).

Press and hold the clear cmos button for 3 seconds then try booting up.




Level 8

Just tried it again, unfortunately no changes to report. 

I'm out of ideas...


Sorry to hear it's still not booting.

Double check all your cables are firmly connected at the psu and the motherboard.  I see your motherboard has an 8-pin cpu power connector and a 4-pin cpu power connector. The motherboard manual shows to have at least the 8-pin cpu power cable connected, or you can connect both.

It's also possible the bios flash didn't go well, did you use the bios renamer to rename the bios file?

power connectors.png







Hi sorry for the late reply, got another MB (same model) and this one works. It was a faulty MB which i will be returning asap.

Thanks for the help!


You're welcome, thank you for coming back and reporting.

Great to hear all is well with your new motherboard.