Showing results for 
Search instead for 
Did you mean: 

Asus Z790-Plus Wifi DDR5 GSkill Trident Z5 4x32 XMP not working!

Level 8
I just bought my motherboard and 128GB (4x32GB) of GSkill DDR5-6400 CL32-39-39-102 1.4V Memory.
The system cannot boot with XMP1 or XMP2 profile. XMP off is no problem. The issue is the RAM runs at 4800 with no XMP. I bought this RAM specifically because it's 6400 and the motherboard is clearly rated to support that memory
4 x DIMM, Max. 128GB, DDR5 7200(OC)/7000(OC)/6800(OC)/6600(OC)/6400(OC)/ 6200(OC)/ 6000(OC)/ 5800(OC)/ 5600/ 5400/ 5200/ 5000/ 4800 Non-ECC, Un-buffered Memory*
I tried 3 BIOS versions including the latest one and it does not work.
Does anyone know how to make fast memory work on this board?
Is it the board the issue?
I don't believe it is the memory because no XMP works fine.
Any help would be greatly appreciated.

Level 14
Assuming you have the TUF board and a 13th gen K/KF-series CPU, there are no 4 DIMM configs for DDR5-6400 on the TUF GAMING Z790-PLUS WIFI Memory QVL. The "socket support" column must be "1,2,4" for a 4 DIMM config; if it is "1,2", that's a 2 DIMM config. The fastest 4 DIMM config on the current QVL for that board and a 13K CPU is DDR5-6000, but that's for 4x16GB; the fastest 4x32GB config on the QVL for a 13K CPU on that board is DDR5-5200. If you have a 12th gen or non-K CPU, there are no 4 DIMM configs on the QVL.

That doesn't mean that you absolutely won't be able to get it to work; it might work with some effort. 4 DIMM configs are harder to get stable than 2 DIMM configs. I suggest trying some speeds between 4800 and 6400, as people have reported some success with 4 DIMM configs and overclocking a bit below the advertised XMP overclock speed. N.B. you need to run a long memory stress test to be certain that it's stable; it's possible to have memory overclocks that can boot but cause crashes later, if they are just a little too fast.

I'd start with trying it at 5600 with the XMP timings, see if that's stable.

In general, you can't have the fastest memory speed and the highest capacity simultaneously. Bigger DIMMs (i.e. 32GB) are harder to overclock than smaller ones, and combining that with a 4 DIMM config is even harder. Note also that combining multiple kits of memory is another thing that can be problematic or add to the difficulty; even if they are identical part numbers.

Lastly, you might find some improvement by updating your BIOS (update the Intel ME (Management Engine) and ME driver first).

Hello thanks for the input.
I've never actually overclocked or played around with the XMP profiles.
Is there anything specific that I need to do, i think that when I select XMP it auto populates everything. Am I able to change anything once the XMP profile is loaded?
Would you know what I need to touch when it comes to other specs when I want to play around with the settings to get the ram to run at different speeds?

Should i do 5600 with xmp 2 or xmp 1

XMP 2 may provide more stability at the DIMMs default timings. Use XMP 1 if not experiencing any instability issues, this is the profile validated by ASUS.

13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Level 14
Yes, you can normally adjust certain things after enabling XMP. Your BIOS will be a bit different to mine (TUF vs. ROG Crosshair), but the basic ability to adjust the RAM speed should be there. You'll want to be in Advanced mode (not EZ mode), and there should be a speed setting a little further down the page from the one that enables XMP. Enable XMP first, which will load the XMP profile/timings, then adjust the speed to see what does and doesn't work.

It's possible that you may need to loosen the timings a little as well (increase the numbers), but try just the speed first to see if you can get any success going above 4800. Looking through the QVL for your board, most of the SK Hynix 32GB DIMMs listed are running at 40-40-40-80. Yours are 32-39-39-102. I'm not an expert on the memory timings, but I'd probably try to see how it behaves on 40-40-40-80 or 40-40-40-102. There should be a memory timings tuning sub-page a bit below the setting that lets you change the speed.

Beyond that, there's the voltage, but your G.SKILL XMP profile is already quite high at 1.4V, and higher than the other 32GB DIMMs on the QVL. I'd be cautious about going any higher than that.

Lastly, I know we'd all love to have 128GB, and we'd all love it to be super-fast, but ask yourself if you actually need that much. 128GB is certainly far more than you need for pretty much all current gaming. Would you be better to have 64GB (2x32GB) running fast, or 128GB running slower? I don't know how you use your machine, what your needs are, etc. Only you can make that choice, but you need to ask yourself that question.

Level 8

Hello Audi911,

I have the same setup and same issues. Updated to latest 904 Bios with no change. I have however been able to get XMP1 and XMP2 working by dropping down to just 2 dimms for a total of 64gig of ram. Hoping for a bios update in the future that addresses this issue. Running 64 gig ram at the full 6400 mem speed. So its a trade off. 128gig at slower speeds, or 64gig full throttle. 

Cheers and good luck!


Level 8

Hey there!

Experienced memory overclocker here.  I think i might be able to help.  *knocks on wood*.  In your bios where it gives you the option to enable xmp, is there a feature that says "manual"?  If so, select manual instead of xmp.  Then set the frequency to 6400mhz.  Then manually set the primary timings to 32-38-38-100 instead of 32-39-39-102.  Make sure you set command rate to 2T.  Manually set your ddr vddq voltages both to 1.4v and set the IVR vddq voltage to 1.4v.  Manually set both the system agent voltage and the memory controller voltage both to 1.3v each.  Try to boot.  If it doesn't boot, try setting both the system agent voltage and the memory controller voltages each to 1.35v.  See if it boots.  If it doesn't boot, reset your cmos and try using 32-38-38-101 for the primary timings while starting at 1.3v system agent voltage + 1.3v memory controller voltage to start.  See if it boots.  If not, try 1.35v system agent voltage and 1.35v memory controller voltage.  These suggestions are based off of myself and other users having to set slightly tighter timings(32-38-38 instead of 32-39-39) to get ddr5 6400mhz 32-39-39 kits to work at the rated speed on various platforms. 


Please let me know how it turns out.


Thanks for the fix info. I however am not highly experienced in overclocking so will take some digging and research to establish these settings. Some are self explanitory, others however are a bit confusing ie. I was able to find 2N command rate but not 2T.  Not looking for hand holding through this process, but will give it a try and keep you posted.

Cheers Tf

Level 7


I use a Strix ROG z790H with Trident z5 RGB @6000 mhz CL30 and I have 64G total 16Gx4. Using with 13700k. I built this around 4-5 months ago but I've not had issues. My ram is made for the 6k OC so I use xmp 1 and an offset voltage 0.13000 and my P cores are between 5.2 & 5.4. , E cores 4.1 & 4.2. Even before my offset voltage tweaks xmp 1 @6k worked fine. Hopefully you found a solution to this. I would be extremely upset. I would write a letter to Asus and demand a fix or swap for maybe a z790H like I have. I believe it's almost same price (I paid $299) But I'd most definitely send a few detailed emails to asus and tell them I'm upset and I've been a customer many years and I know many people and I will write reviews as I always do about ny experience with this. Please let me know something about this at your earliest convenience. Thanks for your time. Please don't not reply to this. I've heard many negative things about Asus recently and this is the first time I've had issues. I don't want to be another person who adds to the negativity that Asus has gotten recently but if this isn't answered and something isn't done to resolve it soon I'll have no choice but to speak openly about my experience. Thanks for your time. I believe sometimes it's how you communicate with people that may or may not get you what you are needing resolved. I know I've been on the other side of things similar before where I had people tell me they weren't pleased with this or that and I always tried to do what I could but there were times where some people were rude and others were more respectful at communicating with me and I was definitely more inclined to helping the people who talked to me in a detailed not aggressive way. When someone has a bad experience and doesn't write a review about anything if they never got whatever resolved that's not good. I believe everyone should write about such experiences but when people come off as aggressive sometimes that can cause said customer to not get the help that they need. 

My first thoughts when reading your op was bios update. Hopefully you're good now. If not I'd be asking for a z790H Strix ROG board. If I was ignored or it didn't get resolved I would express my feelings in a detailed manner on a few known sites and write them a few letters. 

(Edit, typo)

ASUS ROG Strix z790H, 13700K, Trident Z5 Gskill 16Gx4 (64G) RGB CL30 DDR5, Noctua D15 Chromax single fan mode, (5) Noctua S12A Chromax case fans other cooler fan in top. Arc a750, MSI A850GF, Corsair 4000D blk MT airflow case, MSI MP271C PRO curved 1080 monitor white, Corsair K55 RGB PRO XT wired keyboard, (4) M2 SSDs 3TB, (3) HDDs 3.5TB (1) SATA3 SSD 500G, (3) RGB LED 12v light strips, Arctic MX6 thermal paste (good paste!) Kali Linux (FDE) (ext4) & Xero Linux (btrfs) on diff SSDs